summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2008-02-01 16:30:08 +0100
committerSimon Josefsson <simon@josefsson.org>2008-02-01 16:30:08 +0100
commit409d8d760cb2e18ead63a7276ed3489ceaf096b1 (patch)
tree8dad1db5bbbe8c5a2203c49992051ef20ea82d53 /src/Makefile.am
parenta0995a80a7c94600f6b46923cf3c0794aae86d4e (diff)
downloadlibtasn1-409d8d760cb2e18ead63a7276ed3489ceaf096b1.tar.gz
libtasn1-409d8d760cb2e18ead63a7276ed3489ceaf096b1.tar.bz2
libtasn1-409d8d760cb2e18ead63a7276ed3489ceaf096b1.zip
Build pkix_asn1_tab.c using asn1Parser.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1d6290d..e4919ef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
## Process this file with automake to produce Makefile.in
-# Copyright (C) 2002, 2003, 2004, 2005, 2006, 2007 Free Software Foundation
+# Copyright (C) 2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation
#
# This file is part of LIBTASN1.
#
@@ -34,3 +34,9 @@ asn1Decoding_SOURCES = asn1Decoding.c
CertificateExample_SOURCES = CertificateExample.c
CrlExample_SOURCES = CrlExample.c
+
+BUILT_SOURCES = pkix_asn1_tab.c
+MAINTAINERCLEANFILES = pkix_asn1_tab.c
+
+pkix_asn1_tab.c: asn1Parser $(srcdir)/pkix.asn
+ -./asn1Parser -o $@ $(srcdir)/pkix.asn