summaryrefslogtreecommitdiff
path: root/gl/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2010-09-30 17:28:55 +0200
committerSimon Josefsson <simon@josefsson.org>2010-09-30 17:28:55 +0200
commitef747ffc58f3acf81dba4cb0235822cd089943bc (patch)
tree73324929795cce7286c8a9129e9ba3f4be971a33 /gl/Makefile.am
parentc394d8129e75bb86141812cd1129cdbc673937fc (diff)
downloadlibtasn1-ef747ffc58f3acf81dba4cb0235822cd089943bc.tar.gz
libtasn1-ef747ffc58f3acf81dba4cb0235822cd089943bc.tar.bz2
libtasn1-ef747ffc58f3acf81dba4cb0235822cd089943bc.zip
Update gnulib files.
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index a89d909..574688f 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -541,13 +541,16 @@ BUILT_SOURCES += sys/wait.h
# We need the following in order to create <sys/wait.h> when the system
# has one that is incomplete.
-sys/wait.h: sys_wait.in.h
+sys/wait.h: sys_wait.in.h $(CXXDEFS_H) $(WARN_ON_USE_H)
$(AM_V_at)$(MKDIR_P) sys
$(AM_V_GEN)rm -f $@-t $@ && \
{ echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
-e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
-e 's|@''NEXT_SYS_WAIT_H''@|$(NEXT_SYS_WAIT_H)|g' \
+ -e 's|@''GNULIB_WAITPID''@|$(GNULIB_WAITPID)|g' \
+ -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \
+ -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)' \
< $(srcdir)/sys_wait.in.h; \
} > $@-t && \
mv $@-t $@