summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPawel Kowalski <p.kowalski2@partner.samsung.com>2019-08-28 14:28:40 +0200
committerPawel Kowalski <p.kowalski2@partner.samsung.com>2019-08-28 14:28:40 +0200
commit26bea900a531662c6028ecc06f4adea825658434 (patch)
tree1db3d30bddc8b8336fa7a8f2bf5a3615001071e1 /configure.ac
parente527f54afdf27ab8ce73a22d05d69e5482f5e92b (diff)
downloadlibtasn1-26bea900a531662c6028ecc06f4adea825658434.tar.gz
libtasn1-26bea900a531662c6028ecc06f4adea825658434.tar.bz2
libtasn1-26bea900a531662c6028ecc06f4adea825658434.zip
Imported Upstream version 4.14upstream/4.14
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 26 insertions, 43 deletions
diff --git a/configure.ac b/configure.ac
index 45d0233..3065c86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,12 +16,12 @@ dnl Process this file with autoconf to produce a configure script.
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-AC_PREREQ([2.61])
-AC_INIT([GNU Libtasn1],[4.13],[help-libtasn1@gnu.org])
+AC_PREREQ([2.63])
+AC_INIT([GNU Libtasn1],[4.14],[help-libtasn1@gnu.org])
AC_CONFIG_AUX_DIR([build-aux])
-AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_MACRO_DIRS([m4 m4-gl])
AC_CONFIG_HEADERS(config.h)
-AM_INIT_AUTOMAKE([1.10 -Wall -Wno-override])
+AM_INIT_AUTOMAKE([1.10 foreign -Wall -Wno-override])
AM_SILENT_RULES([yes])
# Library code modified: REVISION++
@@ -29,12 +29,21 @@ AM_SILENT_RULES([yes])
# Interfaces added: AGE++
# Interfaces removed: AGE=0
AC_SUBST(LT_CURRENT, 11)
-AC_SUBST(LT_REVISION, 5)
+AC_SUBST(LT_REVISION, 6)
AC_SUBST(LT_AGE, 5)
+# Generate version defines for include file
+AC_SUBST([ASN1_VERSION_MAJOR], [`echo $VERSION|cut -d'.' -f1`])
+AC_SUBST([ASN1_VERSION_MINOR], [`echo $VERSION|cut -d'.' -f2`])
+# Let's activate the following line as soon as we change to extended version numbering
+#AC_SUBST([ASN1_VERSION_PATCH], [`echo $VERSION|cut -d'.' -f3`])
+AC_SUBST([ASN1_VERSION_PATCH], [`echo 0`])
+AC_SUBST([ASN1_VERSION_NUMBER], [`printf '0x%02x%02x%02x' $ASN1_VERSION_MAJOR $ASN1_VERSION_MINOR $ASN1_VERSION_PATCH`])
+AC_CONFIG_FILES([lib/includes/libtasn1.h])
+
+
AC_PROG_CC
gl_EARLY
-lgl_EARLY
AC_PROG_YACC
AC_ARG_ENABLE(doc,
@@ -42,6 +51,8 @@ AC_ARG_ENABLE(doc,
enable_doc=$enableval, enable_doc=yes)
AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" != "no")
+AC_CHECK_FUNCS([clock_gettime])
+
dnl Checks for programs.
AM_MISSING_PROG(HELP2MAN, help2man, $missing_dir)
AC_LIBTOOL_WIN32_DLL
@@ -52,11 +63,8 @@ GTK_DOC_CHECK(1.2)
AC_CHECK_SIZEOF(unsigned long int, 4)
AC_CHECK_SIZEOF(unsigned int, 4)
-sj_UPDATE_HEADER_VERSION([$srcdir/lib/libtasn1.h])
-
# For gnulib compatibility modules.
gl_INIT
-lgl_INIT
AC_ARG_ENABLE([gcc-warnings],
[AS_HELP_STRING([--disable-gcc-warnings],
@@ -65,51 +73,26 @@ AC_ARG_ENABLE([gcc-warnings],
yes|no) ;;
*) AC_MSG_ERROR([bad value $enableval for gcc-warnings option]) ;;
esac
- gl_gcc_warnings=$enableval],
- [gl_gcc_warnings=yes]
+ gcc_warnings=$enableval],
+ [gcc_warnings=yes]
)
-if test "$gl_gcc_warnings" = yes; then
- nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
- nw="$nw -Wc++-compat" # We don't care strongly about C++ compilers
- nw="$nw -Wtraditional" # Warns on #elif which we use often
- nw="$nw -Wtraditional-conversion" # Too many warnings for now
- nw="$nw -Wconversion" # Too many warnings for now
- nw="$nw -Wsign-conversion" # Too many warnings for now
- nw="$nw -Wold-style-definition" #
- nw="$nw -Wpadded" # Our structs are not padded
- nw="$nw -Wundef" #
- nw="$nw -Wunreachable-code" # Too many false positives
- nw="$nw -Wunused-macros" # Breaks on bison generated ASN1.c
- nw="$nw -Wswitch-default" # Breaks on bison generated ASN1.c
- nw="$nw -Wunsafe-loop-optimizations"
- nw="$nw -Wstrict-overflow"
- nw="$nw -Woverlength-strings" # Some tests use large strings
- nw="$nw -Wsuggest-attribute=pure" # Is it worth using pure attributes?
-
- gl_MANYWARN_ALL_GCC([ws])
- gl_MANYWARN_COMPLEMENT(ws, [$ws], [$nw])
- for w in $ws; do
- gl_WARN_ADD([$w])
- done
-
- gl_WARN_ADD([-Wno-type-limits])
- gl_WARN_ADD([-Wno-missing-field-initializers])
- gl_WARN_ADD([-Wno-unused-parameter])
- gl_WARN_ADD([-Wno-stack-protector]) # Some functions cannot be protected
- gl_WARN_ADD([-fdiagnostics-show-option])
+WARN_CFLAGS=""
+if test "$gcc_warnings" = yes;then
+ WARN_CFLAGS="$WARN_CFLAGS -Wall"
fi
+AC_SUBST([WARN_CFLAGS])
+
+AX_CODE_COVERAGE
AC_CONFIG_FILES([
Makefile
doc/Makefile
doc/cyclo/Makefile
doc/reference/Makefile
- doc/reference/version.xml
examples/Makefile
- gl/Makefile
lib/Makefile
- lib/gllib/Makefile
+ lib/gl/Makefile
lib/libtasn1.pc
src/Makefile
tests/Makefile