summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPawel Kowalski <p.kowalski2@partner.samsung.com>2018-06-15 11:24:08 +0200
committerPawel Kowalski <p.kowalski2@partner.samsung.com>2018-06-15 11:26:09 +0200
commit5c7e0aaf17a296535495e3431db6a86ad64064b3 (patch)
treed7cca0250c60fbc69eb70a7039d0f9659f81b9d0 /configure.ac
parent1701584f7841a79ae4e97699a8c4ac9f0a09c38f (diff)
parente527f54afdf27ab8ce73a22d05d69e5482f5e92b (diff)
downloadlibtasn1-5c7e0aaf17a296535495e3431db6a86ad64064b3.tar.gz
libtasn1-5c7e0aaf17a296535495e3431db6a86ad64064b3.tar.bz2
libtasn1-5c7e0aaf17a296535495e3431db6a86ad64064b3.zip
Change-Id: I254f6095d312777427a57af3ed346986a28f3aaa
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 1993532..6e925d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,7 @@ dnl Process this file with autoconf to produce a configure script.
# along with this program. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ([2.61])
-AC_INIT([GNU Libtasn1],[4.8],[help-libtasn1@gnu.org])
+AC_INIT([GNU Libtasn1],[4.13],[help-libtasn1@gnu.org])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS(config.h)
@@ -29,7 +29,7 @@ AM_SILENT_RULES([yes])
# Interfaces added: AGE++
# Interfaces removed: AGE=0
AC_SUBST(LT_CURRENT, 11)
-AC_SUBST(LT_REVISION, 2)
+AC_SUBST(LT_REVISION, 5)
AC_SUBST(LT_AGE, 5)
AC_PROG_CC
@@ -59,19 +59,17 @@ gl_INIT
lgl_INIT
AC_ARG_ENABLE([gcc-warnings],
- [AS_HELP_STRING([--enable-gcc-warnings],
- [turn on lots of GCC warnings (for developers)])],
+ [AS_HELP_STRING([--disable-gcc-warnings],
+ [disable GCC warnings (for developers)])],
[case $enableval in
yes|no) ;;
*) AC_MSG_ERROR([bad value $enableval for gcc-warnings option]) ;;
esac
gl_gcc_warnings=$enableval],
- [gl_gcc_warnings=no]
+ [gl_gcc_warnings=yes]
)
if test "$gl_gcc_warnings" = yes; then
- gl_WARN_ADD([-Werror], [WERROR_CFLAGS])
-
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
nw="$nw -Wc++-compat" # We don't care strongly about C++ compilers
nw="$nw -Wtraditional" # Warns on #elif which we use often
@@ -86,6 +84,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wswitch-default" # Breaks on bison generated ASN1.c
nw="$nw -Wunsafe-loop-optimizations"
nw="$nw -Wstrict-overflow"
+ nw="$nw -Woverlength-strings" # Some tests use large strings
nw="$nw -Wsuggest-attribute=pure" # Is it worth using pure attributes?
gl_MANYWARN_ALL_GCC([ws])