summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build36
1 files changed, 29 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 88a08ce1..03884d8f 100644
--- a/meson.build
+++ b/meson.build
@@ -1,8 +1,8 @@
project('libsoup', 'c',
- version: '2.69.90',
+ version: '2.72.0',
meson_version : '>=0.50',
license : 'LGPL2',
- default_options : 'c_std=c89')
+ default_options : 'c_std=c99')
gnome = import('gnome')
@@ -12,9 +12,17 @@ soup_version_major = version_arr[0]
soup_version_minor = version_arr[1]
soup_version_micro = version_arr[2]
-libversion = '1.8.0'
+# Before making a release, the libversion string should be modified.
+#
+# * Bump the first component if binary compatibility has been broken; or
+# * Bump the second component if new APIs are added; or
+# * Bump the third component otherwise.
+#
+# When bumping the first component version, set the second and third components
+# to 0. When bumping the second version, set the third one to zero.
+libversion = '1.11.0'
apiversion = '2.4'
-soversion = '1'
+soversion = libversion.split('.')[0]
libsoup_api_name = '@0@-@1@'.format(meson.project_name(), apiversion)
libversion_arr = libversion.split('.')
darwin_version_major = libversion_arr[0].to_int()
@@ -87,7 +95,7 @@ sqlite_dep = dependency('sqlite3', required: false)
# Fallback check for sqlite, not all platforms ship pkg-config file
if not sqlite_dep.found()
sqlite_dep = cc.find_library('sqlite3',
- has_headers : ['sqlite3.h', 'sqlite3ext.h'],
+ has_headers : ['sqlite3.h'],
required: false)
endif
@@ -143,6 +151,22 @@ if cc.has_function('gmtime_r', prefix : '#include <time.h>', args : default_sour
cdata.set('HAVE_GMTIME_R', '1')
endif
+# sysprof support
+libsysprof_capture_dep = dependency('sysprof-capture-4',
+ required: get_option('sysprof'),
+ default_options: [
+ 'enable_examples=false',
+ 'enable_gtk=false',
+ 'enable_tests=false',
+ 'enable_tools=false',
+ 'libsysprof=false',
+ 'with_sysprofd=none',
+ 'help=false',
+ ],
+ fallback: ['sysprof', 'libsysprof_capture_dep'],
+)
+cdata.set('HAVE_SYSPROF', libsysprof_capture_dep.found())
+
###################
# GIO TLS support #
###################
@@ -272,8 +296,6 @@ if not tests_ready
warning('Some regression tests will not be compiled due to missing libraries or modules. Please check the logs for more details.')
endif
-cdata.set('HAVE_CURL', find_program('curl', required : false).found())
-
##################
# GSSAPI support #
##################