summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 96bb378a..369e9317 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,30 @@ dnl *** Misc checks ***
dnl *******************
AC_CHECK_FUNCS(gmtime_r)
+dnl *************************
+dnl *** SQL Lite support independently of gnome for Tizen ***
+dnl *************************
+
+AC_ARG_ENABLE(sqllite,
+ AS_HELP_STRING([--enable-sqllite], [Enable SQL lite support ]), ,
+ enable_sqllite=no)
+
+if test "$enable_sqllite" != "no"; then
+ PKG_CHECK_MODULES(SQLITE, sqlite3, :, [AC_MSG_ERROR(dnl
+[Could not find sqlite3 devel files:
+
+$SQLITE_PKG_ERRORS
+
+Pass "--without-sqlite" to configure if you want to build libsoup
+without sql lite support.])])
+
+fi
+
+AC_SUBST(SQLITE_CFLAGS)
+AC_SUBST(SQLITE_LIBS)
+
+AM_CONDITIONAL(SQLLITE_SUPPORT, [test $enable_sqllite = yes])
+
dnl *********************
dnl *** GNOME support ***
dnl *********************