summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2012-10-22 20:15:49 +0200
committerDan Winship <danw@gnome.org>2012-10-22 20:15:49 +0200
commitaf44b7b8df5bcb9bb304e36ffad9b65c6ee22594 (patch)
tree376bf7c52658e37ae70ec2d42937d774666afa74 /tests/Makefile.am
parent07ad1e0728553817e7b9be9b4d192383760c201e (diff)
downloadlibsoup-af44b7b8df5bcb9bb304e36ffad9b65c6ee22594.tar.gz
libsoup-af44b7b8df5bcb9bb304e36ffad9b65c6ee22594.tar.bz2
libsoup-af44b7b8df5bcb9bb304e36ffad9b65c6ee22594.zip
tests: add support for Apache 2.4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am26
1 files changed, 23 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 085a81b3..54ce7bdb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -89,10 +89,29 @@ endif
if HAVE_CURL
CURL_TESTS = forms-test server-auth-test
endif
-if HAVE_XMLRPC_EPI_PHP
+if HAVE_XMLRPC_PHP
XMLRPC_TESTS = xmlrpc-test xmlrpc-server-test
endif
+if HAVE_APACHE
+if HAVE_APACHE_2_2
+httpd_conf_in = httpd.conf.22.in
+else
+httpd_conf_in = httpd.conf.24.in
+endif
+httpd.conf: $(httpd_conf_in)
+ $(AM_V_GEN) sed -e 's,[@]srcdir@,$(srcdir),' \
+ -e 's,[@]builddir@,$(builddir),' \
+ -e 's,[@]APACHE_MODULE_DIR@,$(APACHE_MODULE_DIR),' \
+ -e 's,[@]APACHE_PHP_MODULE_DIR@,$(APACHE_PHP_MODULE_DIR),' \
+ -e 's,[@]APACHE_PHP_MODULE@,$(APACHE_PHP_MODULE),' \
+ -e 's,[@]IF_HAVE_PHP@,$(IF_HAVE_PHP),' \
+ -e 's,[@]APACHE_SSL_MODULE_DIR@,$(APACHE_SSL_MODULE_DIR),' \
+ $< > $@ || rm -f $@
+
+BUILT_SOURCES = httpd.conf
+endif
+
soup-tests.gresource: soup-tests.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/soup-tests.gresource.xml)
$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) $<
@@ -138,7 +157,8 @@ RESOURCES = \
EXTRA_DIST = \
htdigest \
htpasswd \
- httpd.conf.in \
+ httpd.conf.22.in \
+ httpd.conf.24.in \
index.txt \
libsoup.supp \
soup-tests.gresource.xml \
@@ -147,7 +167,7 @@ EXTRA_DIST = \
xmlrpc-server.php \
$(RESOURCES)
-DISTCLEANFILES = soup-tests.gresource
+DISTCLEANFILES = soup-tests.gresource httpd.conf
if MISSING_REGRESSION_TEST_PACKAGES
check-local: check-TESTS