summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2013-02-22 22:13:33 +0100
committerDan Winship <danw@gnome.org>2013-02-23 12:01:01 +0100
commit4e9713343934fc2aba5d81ab12fccd64cc24a99f (patch)
treeeedfde0226515669cfaba0a6c8bcb3bf19999c7b /configure.ac
parent926105bc58f373726baeb7567a264a53903b2836 (diff)
downloadlibsoup-4e9713343934fc2aba5d81ab12fccd64cc24a99f.tar.gz
libsoup-4e9713343934fc2aba5d81ab12fccd64cc24a99f.tar.bz2
libsoup-4e9713343934fc2aba5d81ab12fccd64cc24a99f.zip
build: remove some cruft
Remove accumulated cruft, mostly from things we used to depend on but don't any more. Also a few minor drive-by configure cleanups
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 7 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index d6c97ee4..68293d39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,12 +63,6 @@ fi
AC_SUBST(SOUP_DEBUG_FLAGS)
-# Set the maintainer flags
-#if test -d .git; then
-# SOUP_MAINTAINER_FLAGS="-DG_DISABLE_DEPRECATED"
-#fi
-AC_SUBST(SOUP_MAINTAINER_FLAGS)
-
dnl ***************************
dnl *** Checks for programs ***
dnl ***************************
@@ -130,7 +124,6 @@ dnl *******************
dnl *** Misc checks ***
dnl *******************
AC_CHECK_FUNCS(gmtime_r)
-AC_CHECK_FUNC(socket, , AC_CHECK_LIB(socket, socket))
dnl *********************
dnl *** GNOME support ***
@@ -165,7 +158,7 @@ save_LIBS="$LIBS"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
LIBS="$LIBS $GLIB_LIBS"
AC_RUN_IFELSE([AC_LANG_PROGRAM([#include <gio/gio.h>],
- [g_type_init (); return !g_tls_backend_supports_tls (g_tls_backend_get_default ());])],
+ [return !g_tls_backend_supports_tls (g_tls_backend_get_default ());])],
[have_glib_networking=yes],
[have_glib_networking=no],
[have_glib_networking="unknown (cross-compiling)"])
@@ -310,12 +303,15 @@ else
MISSING_REGRESSION_TEST_PACKAGES="$MISSING_REGRESSION_TEST_PACKAGES curl"
fi
-GLIB_COMPILE_RESOURCES=`$PKG_CONFIG --variable glib_compile_resources gio-2.0`
-AC_SUBST(GLIB_COMPILE_RESOURCES)
-
AC_SUBST(MISSING_REGRESSION_TEST_PACKAGES)
AM_CONDITIONAL(MISSING_REGRESSION_TEST_PACKAGES, test -n "$MISSING_REGRESSION_TEST_PACKAGES")
+dnl *********************
+dnl *** resource compiler
+dnl *********************
+GLIB_COMPILE_RESOURCES=`$PKG_CONFIG --variable glib_compile_resources gio-2.0`
+AC_SUBST(GLIB_COMPILE_RESOURCES)
+
dnl **********************************************************
dnl *** path of NTLM single-sign-on helper ntlm_auth
dnl **********************************************************