summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2013-02-19 19:21:35 -0500
committerDan Winship <danw@gnome.org>2013-02-19 19:21:35 -0500
commit3af28bc8e78a7f281b68c36ffe515b5c8a17e507 (patch)
treefb78f3d81ac5b5d8b7f17538472bf2ef1a7d1d59 /configure.ac
parent98144c40bd5614237d23a95d068b8036af7af9ef (diff)
downloadlibsoup-3af28bc8e78a7f281b68c36ffe515b5c8a17e507.tar.gz
libsoup-3af28bc8e78a7f281b68c36ffe515b5c8a17e507.tar.bz2
libsoup-3af28bc8e78a7f281b68c36ffe515b5c8a17e507.zip
tests: do skipped tests properly
automake interprets exit code 77 as meaning "skipped", so have the various apache-dependent, php-dependent, and curl-dependent tests do that, and compile them unconditionally. (Although, to avoid "unused" warnings, we end up #ifdeffing out the whole file.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 1b120812..d6c97ee4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,29 +288,27 @@ if test "$have_apache" = 1; then
MISSING_REGRESSION_TEST_PACKAGES="$MISSING_REGRESSION_TEST_PACKAGES php5"
fi
AC_MSG_RESULT($have_php)
+ AC_SUBST(IF_HAVE_PHP)
if test "$have_php" = yes; then
- AC_MSG_CHECKING([for xmlrpc-php])
+ AC_MSG_CHECKING([for php-xmlrpc])
if $PHP --rf xmlrpc_server_create | grep -q "does not exist"; then
- have_xmlrpc_php=no
+ have_php_xmlrpc=no
MISSING_REGRESSION_TEST_PACKAGES="$MISSING_REGRESSION_TEST_PACKAGES php-xmlrpc"
else
- have_xmlrpc_php=yes
+ have_php_xmlrpc=yes
+ AC_DEFINE(HAVE_PHP_XMLRPC, 1, [Have php-xmlrpc])
fi
- AC_MSG_RESULT($have_xmlrpc_php)
+ AC_MSG_RESULT($have_php_xmlrpc)
fi
fi
-AC_SUBST(IF_HAVE_PHP)
-AM_CONDITIONAL(HAVE_XMLRPC_PHP, test "$have_xmlrpc_php" = yes)
-
AC_PATH_PROG(CURL, curl, no)
if test "$CURL" != no; then
AC_DEFINE(HAVE_CURL, 1, [Whether or not curl can be used for tests])
else
MISSING_REGRESSION_TEST_PACKAGES="$MISSING_REGRESSION_TEST_PACKAGES curl"
fi
-AM_CONDITIONAL(HAVE_CURL, test "$CURL" != no)
GLIB_COMPILE_RESOURCES=`$PKG_CONFIG --variable glib_compile_resources gio-2.0`
AC_SUBST(GLIB_COMPILE_RESOURCES)