summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2012-09-20 17:02:40 -0700
committerDan Winship <danw@gnome.org>2012-10-22 18:48:02 +0200
commit33cf3c6f2530732e85a93d42c153db53844feebb (patch)
treeb2879f7b77babac881cf19a37ae87654e8ccf18a /configure.ac
parentcbbde758b8ea533916fe25dc25d64bac564ea09a (diff)
downloadlibsoup-33cf3c6f2530732e85a93d42c153db53844feebb.tar.gz
libsoup-33cf3c6f2530732e85a93d42c153db53844feebb.tar.bz2
libsoup-33cf3c6f2530732e85a93d42c153db53844feebb.zip
Add API to get version information
Expose API to get information about the soup version. This is useful because it allows applications to use API without actually depending on it completely. https://bugzilla.gnome.org/show_bug.cgi?id=684514
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a6b2b708..438df9c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,8 +2,12 @@ dnl *******************************************
dnl *** Initialize automake and set version ***
dnl *******************************************
+m4_define([soup_major_version], [2])
+m4_define([soup_minor_version], [41])
+m4_define([soup_micro_version], [0])
+
AC_PREREQ(2.63)
-AC_INIT([libsoup],[2.41.0],[http://bugzilla.gnome.org/enter_bug.cgi?product=libsoup])
+AC_INIT([libsoup],[soup_major_version.soup_minor_version.soup_micro_version],[http://bugzilla.gnome.org/enter_bug.cgi?product=libsoup])
AC_CONFIG_SRCDIR([libsoup-2.4.pc.in])
AC_CONFIG_MACRO_DIR([m4])
@@ -12,6 +16,13 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])],)
AC_PROG_MAKE_SET
+SOUP_MAJOR_VERSION=soup_major_version
+SOUP_MINOR_VERSION=soup_minor_version
+SOUP_MICRO_VERSION=soup_micro_version
+AC_SUBST(SOUP_MAJOR_VERSION)
+AC_SUBST(SOUP_MINOR_VERSION)
+AC_SUBST(SOUP_MICRO_VERSION)
+
SOUP_API_VERSION=2.4
AC_SUBST(SOUP_API_VERSION)
@@ -365,6 +376,7 @@ AC_CONFIG_FILES([
tests/httpd.conf
docs/Makefile
docs/reference/Makefile
+ libsoup/soup-version.h
])
AC_OUTPUT