summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoralex <alex>2000-12-06 22:28:48 +0000
committeralex <alex>2000-12-06 22:28:48 +0000
commitee40cef78df148f9f96978e0be9e591edfa5853d (patch)
tree0ca7a10fffde54a3756c220a1707f84c1f4d7116 /Makefile.am
downloadlibsoup-ee40cef78df148f9f96978e0be9e591edfa5853d.tar.gz
libsoup-ee40cef78df148f9f96978e0be9e591edfa5853d.tar.bz2
libsoup-ee40cef78df148f9f96978e0be9e591edfa5853d.zip
Initial version
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..45d5428d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,28 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = src
+
+EXTRA_DIST = \
+ autogen.sh
+
+install-data-local:
+ @$(NORMAL_INSTALL)
+ if test -d $(srcdir)/pixmaps; then \
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
+ for pixmap in $(srcdir)/pixmaps/*; do \
+ if test -f $$pixmap; then \
+ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
+ fi \
+ done \
+ fi
+
+dist-hook:
+ if test -d pixmaps; then \
+ mkdir $(distdir)/pixmaps; \
+ for pixmap in pixmaps/*; do \
+ if test -f $$pixmap; then \
+ cp -p $$pixmap $(distdir)/pixmaps; \
+ fi \
+ done \
+ fi
+