summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2002-11-05 19:45:46 +0000
committerDan Winship <danw@src.gnome.org>2002-11-05 19:45:46 +0000
commitd4629510fb547f3ed2cce829ea1ec0c73bc5647c (patch)
tree19ee5b614bf12a0aa2ebd29d8a9fd2535dea8386 /Makefile.am
parent6314c214c92e43c84be54754013580ecb475b486 (diff)
downloadlibsoup-d4629510fb547f3ed2cce829ea1ec0c73bc5647c.tar.gz
libsoup-d4629510fb547f3ed2cce829ea1ec0c73bc5647c.tar.bz2
libsoup-d4629510fb547f3ed2cce829ea1ec0c73bc5647c.zip
Split libsoup out of soup. ChangeLog.old contains the original soup
* Split libsoup out of soup. ChangeLog.old contains the original soup ChangeLog. * Makefile.am, etc: Fix things up to work with the new directory layout. Disable docs until we fix them. * autogen.sh: Use gnome-autogen.sh * configure.in: Require autoconf 2.53. Remove stuff that was only needed for httpd or wsdl code. Remove glib1 support. Bump version to 2.0. * libsoup/Makefile.am: Rename library to libsoup-2.0, put includes in ${includedir}/soup-2.0 * libsoup/*: Merge soup-0-7 back onto the trunk. Remove SOAP-specific stuff, Windows support, and other things that weren't being maintained. * soup-config.in, soupConf.sh: Kill these. We only support pkg-config now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am60
1 files changed, 3 insertions, 57 deletions
diff --git a/Makefile.am b/Makefile.am
index 8559c7cb..5b2c4dff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,63 +1,9 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = src docs
+SUBDIRS = libsoup
-# I want to include tests in the distributed version, but that requires
-# some automake deep magic to stop it trying to include generated files in
-# the automated dependency logic. (hint: OMIT_DEPENDENCIES did SFA)
-#DIST_SUBDIRS = $(SUBDIRS) tests
-
-EXTRA_DIST = \
- autogen.sh \
- soupConf.sh.in \
- soup_apacheConf.sh.in \
- soup_wsdlConf.sh.in \
- soup.m4 \
- soup.pc.in \
- soup.spec.in
-
-bin_SCRIPTS = soup-config
-
-soupConf.sh: $(top_srcdir)/soupConf.sh.in Makefile
- sed -e 's?\@SOUP_LIBDIR\@?$(SOUP_LIBDIR)?g' \
- -e 's?\@SOUP_INCLUDEDIR\@?$(SOUP_INCLUDEDIR)?g' \
- -e 's?\@VERSION\@?$(VERSION)?g' \
- -e 's?\@SOUP_LIBS\@?$(SOUP_LIBS)?g' \
- < $(top_srcdir)/soupConf.sh.in > soupConf.tmp \
- && mv soupConf.tmp soupConf.sh
-
-soup_apacheConf.sh: $(top_srcdir)/soup_apacheConf.sh.in Makefile
- sed -e 's?\@SOUP_APACHE_LIBDIR\@?$(SOUP_APACHE_LIBDIR)?g' \
- -e 's?\@SOUP_APACHE_INCLUDEDIR\@?$(SOUP_APACHE_INCLUDEDIR)?g' \
- -e 's?\@VERSION\@?$(VERSION)?g' \
- -e 's?\@SOUP_APACHE_LIBS\@?$(SOUP_APACHE_LIBS)?g' \
- < $(top_srcdir)/soup_apacheConf.sh.in > soup_apacheConf.tmp \
- && mv soup_apacheConf.tmp soup_apacheConf.sh
-
-soup_wsdlConf.sh: $(top_srcdir)/soup_wsdlConf.sh.in Makefile
- sed -e 's?\@SOUP_WSDL_LIBDIR\@?$(SOUP_WSDL_LIBDIR)?g' \
- -e 's?\@SOUP_WSDL_INCLUDEDIR\@?$(SOUP_WSDL_INCLUDEDIR)?g' \
- -e 's?\@VERSION\@?$(VERSION)?g' \
- -e 's?\@SOUP_WSDL_LIBS\@?$(SOUP_WSDL_LIBS)?g' \
- < $(top_srcdir)/soup_wsdlConf.sh.in > soup_wsdlConf.tmp \
- && mv soup_wsdlConf.tmp soup_wsdlConf.sh
-
-confexecdir = $(libdir)
-confexec_DATA = soupConf.sh soup_apacheConf.sh soup_wsdlConf.sh
-
-m4datadir = $(datadir)/aclocal
-m4data_DATA = soup.m4
+EXTRA_DIST = soup-2.0.pc.in
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = soup.pc
-
-examples:
- $(MAKE) -C tests
-
-dist-hook: soup.spec
- cp soup.spec $(distdir)
-
-rpms: distcheck
- rpm -ta $(top_builddir)/@PACKAGE@-@VERSION@.tar.gz
+pkgconfig_DATA = soup-2.0.pc
-CLEANFILES = soupConf.sh soup_apacheConf.sh soup_wsdlConf.sh