summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDick Porter <dick@ximian.com>2001-05-17 16:03:11 +0000
committerDick Porter <dick@src.gnome.org>2001-05-17 16:03:11 +0000
commitc4fabfc9505a81322ce0d1a9011bf20b25c717ed (patch)
treef2faa7d6800f68204464c6448775d26777f9174a /Makefile.am
parentd83827ff2971d1cb4fa677adcb03c2d57995f8fa (diff)
downloadlibsoup-c4fabfc9505a81322ce0d1a9011bf20b25c717ed.tar.gz
libsoup-c4fabfc9505a81322ce0d1a9011bf20b25c717ed.tar.bz2
libsoup-c4fabfc9505a81322ce0d1a9011bf20b25c717ed.zip
Extract gtk-doc documentation from the code
2001-05-17 Dick Porter <dick@ximian.com> * docs/reference: Extract gtk-doc documentation from the code * tests/test-wsdl-runtime.c: * tests/stockquote2-server.c: * tests/stockquote2-client.c: Updated for new API * tests/stress-test.c: * tests/simple-test.c: Include installed soup headers * configure.in: Check for gtk-doc * tests/Makefile.am: Made example code just plain "noinst_PROGRAMS", check_PROGRAMS are built as part of "make dist". Wrestled with automake, automake won :-( I wanted to delete the built sources from the dist target, and not have automake try and recreate them with a non-existant soup-wsdl when I type "make distcheck". * Makefile.am: Took tests out of SUBDIRS, added a "make examples" target instead.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 524325f1..99b994cd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,13 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = src tests
+SUBDIRS = src docs
-EXTRA_DIST = autogen.sh soupConf.sh.in soup_apacheConf.sh.in soup.pc.in soup.spec.in
+# I want to include tests in the distributed version, but that requires
+# some automake deep magic to stop it trying to include generated files in
+# the automated dependency logic. (hint: OMIT_DEPENDENCIES did SFA)
+#DIST_SUBDIRS = $(SUBDIRS) tests
+
+EXTRA_DIST = autogen.sh soupConf.sh.in soup_apacheConf.sh.in soup_wsdlConf.sh.in soup.pc.in soup.spec.in
bin_SCRIPTS = soup-config
@@ -36,10 +41,13 @@ confexec_DATA = soupConf.sh soup_apacheConf.sh soup_wsdlConf.sh
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = soup.pc
+examples:
+ $(MAKE) -C tests
+
dist-hook: soup.spec
cp soup.spec $(distdir)
rpms: distcheck
rpm -ta $(top_builddir)/@PACKAGE@-@VERSION@.tar.gz
-CLEANFILES = soupConf.sh
+CLEANFILES = soupConf.sh soup_apacheConf.sh soup_wsdlConf.sh