summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2008-10-31 17:55:32 +0000
committerDan Winship <danw@src.gnome.org>2008-10-31 17:55:32 +0000
commitbf8076f3277959cae864649b82d1427af5f59ee3 (patch)
treea5c75b1cbf22e26fe9e93c2bb43eb9e9c962a0fa /Makefile.am
parent95ee5e3f7a110f1f68f73136d95e590d05818012 (diff)
downloadlibsoup-bf8076f3277959cae864649b82d1427af5f59ee3.tar.gz
libsoup-bf8076f3277959cae864649b82d1427af5f59ee3.tar.bz2
libsoup-bf8076f3277959cae864649b82d1427af5f59ee3.zip
rename from libsoup.pc.in; the attempt to keep the source tree
* libsoup-2.4.pc.in: rename from libsoup.pc.in; the attempt to keep the source tree API-version-generic wasn't really working, and we're probably not ever going to change the API version again anyway. * Makefile.am (pkgconfig_DATA): install the .pc file the normal way rather than using an install-data-local rule to rename the .pc file as we install it * libsoup/Makefile.am (libsoupincludedir): * tests/Makefile.am (LIBS): * docs/reference/Makefile.am (GTKDOC_LIBS): Say "2.4" everywhere, instead of 2.4 in some places and $(SOUP_API_VERSION) in others. * configure.in: updates for .pc renaming. Also, use AS_HELP_STRING() in AC_ARG_ENABLE() and AC_ARG_WITH() rules svn path=/trunk/; revision=1193
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 0f10ceeb..2b621d5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,15 +3,14 @@ AUTOMAKE_OPTIONS = 1.6
SUBDIRS = libsoup tests docs
-EXTRA_DIST = libsoup.pc.in gtk-doc.make libsoup-zip.in
+EXTRA_DIST = \
+ libsoup-2.4.pc.in \
+ gtk-doc.make \
+ libsoup-zip.in
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
pkgconfigdir = $(libdir)/pkgconfig
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pkgconfigdir)
- $(INSTALL) -m 644 libsoup.pc $(DESTDIR)$(pkgconfigdir)/libsoup-$(SOUP_API_VERSION).pc
+pkgconfig_DATA = libsoup-2.4.pc
-uninstall-local:
- rm -f $(DESTDIR)$(pkgconfigdir)/libsoup-$(SOUP_API_VERSION).pc