Age | Commit message (Collapse) | Author | Files | Lines |
|
Also change dumpsolv to use solv_chksum_type2str instead of printing
the internal type.
|
|
We also use this to reorder knownid.h, thus breaking
the libsolv ABI. Next step is to bump the version.
|
|
|
|
|
|
|
|
|
|
|
|
stay somewhat compatible
|
|
|
|
couple of months earlier, sorry.
|
|
|
|
|
|
repo->repoid)
Also make repo->free not renumber the repos, instead we leave a hole (like with
the solvables).
|
|
|
|
|
|
|
|
- fix solvable_lookup_str_poollang bug
- add support for REPOKEY_TYPE_BINARY
- do not add provides when extending susetags solvables
- fix susetags language handling in demo application
|
|
REPO_LOCALPOOL - create local pool
REPO_EXTEND_SOLVABLES - extend existing solvables instead of creating new ones
REPO_USE_LOADING - replace repodata in state loading
- add repo_add_solv_flags to make repo_add_solv use flags
- make repo_add_solv obey the flags instead of using defaults if this is a subload
- change loadcallback definition to return a boolean, the callback is now
responsible for the loading
- change repo_write so that the keyfilter can select which repodata to use (hack)
- change pool_addfileprovides to load the complete filelist if needed
- add SEARCH_COMPLETE_FILELIST flag to searches
- add transaction_create_installedmap/transaction_calc_installsizechange
|
|
|
|
- add pool argument to datamatcher_init
- add flags argument to repodata_search
- only add sentinal if SEARCH_SENTINEL is specified
- use kv.eof == 2 for sentinel like before
- rename dataiterator_match to dataiterator_match_obsolete
- add repodata_stringify function
- make datamatcher match simple strings so it can be reused
- add dataiterator_prepend_keyname to match keyname pathes
- rename dataiterator_jump_to_solvable to dataiterator_jump_to_solvid
|
|
|
|
|
|
|
|
- incompatible new file format
- repodata handles are solvable ids
- no more extra handles
- no need to call repodata_extend anymore
- work around solver dup repo priority bug, real fix follows soon
|
|
extra flag, because this is fairly costly. Intended for user-controled
queries, _not_ to be used by the solver or the like.
|
|
|
|
|
|
them too, but not yet nested, so that is unsupported for now.
|
|
|
|
iterator functions.
|
|
have attributes, but are not solvables). The usual functions interpret
negative entry numbers as those (positive ones are solvable IDs). I'll
probably refine the code some more, hence it's work in progress.
susetags2repo: Parse also a "=Lan:" tag, which can be injected
externally when multiple language tag files are catted together.
|
|
|
|
support functions to deal with them being strings). Generate them from the
susetags parser for the =Cks tags.
|
|
- do not load filelist in addfileproviders if the provides
are already there
- fix some mem leaks
|
|
|
|
|
|
- ignore hardlinked file in DU stats
- print more statistics in dumpsolv
|
|
to all older versions. sorry.
* new fastlz from Matz
* maxsize/allsize data for faster reading
* types are stored as Id to make extensions possible
* new type CONSTANTID
* new file repopack.h
* kill unused vertical/packedsizes flags
- switch to pread for paging so that we don't have to mess with file
offsets
- define more standard IDs
- add new solver_calc_installsizechange() function
- add repo_add_rpms() function
- change location storage method a bit, now VOID means ommited
(adapt zypp code, please)
- re-added support for source rpm name to susetags parser
|
|
|
|
|
|
callback interface (one or all solvables, one or all attributes, with or
without matching), except the solvable data (to be implemented).
Also some inactive (but working) code in dumpsolv testing the iterator.
|
|
- make rpmdb record the filelist (currently just in parts)
- make filelist a vertical
|
|
- print rpmdbid, too
|
|
- add id_filelist
- dump DIRSTRARRAY type
|
|
|
|
|
|
use embedded attrname not an artificial one
|
|
one can even have multiple ones in a single directory now ;-)
|
|
side. Try "susetags2solv -as" to play (e.g. with dumpsolv).
|
|
accessing the name in libzypp and other applications.
Its also in preparation of per-kind solving (not implemented yet).
The name prefix (e.g. "pattern:") is still kept but only needed for
capability matching. kind is implemented as an offset (unsigned int)
matching the length of the name prefix. Applications can simply use
(solvable.name + solvable.kind) to strip the prefix from the name.
To prevent name clashes, "product:" was renamed to "prod:". Being
seldomly used, this seems to be acceptable.
Missing understandable documentation on the format of .solv files, the
kind value is currently NOT stored but computed on read.
tools/repo_susetags.c is already prepared to write the kind, solv
version6 should support storing kind values in .solv files.
|