summaryrefslogtreecommitdiff
path: root/ext/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Schroeder <mls@suse.de>2012-02-02 16:30:41 +0100
committerMichael Schroeder <mls@suse.de>2012-02-02 16:30:41 +0100
commit0589bfb58fca13311e4559bad8b0df1efbc9e3ed (patch)
tree2d32089cc30406d4cae73218049f963cbb16f2c7 /ext/CMakeLists.txt
parent857fe280393400d73dca3f7ca815a815ea9388e0 (diff)
downloadlibsolv-0589bfb58fca13311e4559bad8b0df1efbc9e3ed.tar.gz
libsolv-0589bfb58fca13311e4559bad8b0df1efbc9e3ed.tar.bz2
libsolv-0589bfb58fca13311e4559bad8b0df1efbc9e3ed.zip
- start support for Fedora comps format
Diffstat (limited to 'ext/CMakeLists.txt')
-rw-r--r--ext/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/ext/CMakeLists.txt b/ext/CMakeLists.txt
index b88b7b2..9fc9034 100644
--- a/ext/CMakeLists.txt
+++ b/ext/CMakeLists.txt
@@ -29,6 +29,13 @@ IF (ENABLE_SUSEREPO)
repo_susetags.h repo_zyppdb.h)
ENDIF (ENABLE_SUSEREPO)
+IF (ENABLE_COMPS)
+ SET (libsolvext_SRCS ${libsolvext_SRCS}
+ repo_comps.c)
+ SET (libsolvext_HEADERS ${libsolvext_HEADERS}
+ repo_comps.h)
+ENDIF (ENABLE_COMPS)
+
IF (ENABLE_DEBIAN)
SET (libsolvext_SRCS ${libsolvext_SRCS}
repo_deb.c)