summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Schroeder <mls@suse.de>2009-10-06 11:43:32 +0200
committerMichael Schroeder <mls@suse.de>2009-10-06 11:43:32 +0200
commit2c7f3a88499f548fa962fddf69c9e573f3b18480 (patch)
treec852c718dc84bbeb91b5263abc44f6c129c80f3d /CMakeLists.txt
parent910ad3a912011d4f0414cc92b2666e18428f0ace (diff)
downloadlibsolv-2c7f3a88499f548fa962fddf69c9e573f3b18480.tar.gz
libsolv-2c7f3a88499f548fa962fddf69c9e573f3b18480.tar.bz2
libsolv-2c7f3a88499f548fa962fddf69c9e573f3b18480.zip
- support MULTI_SEMANTICS option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f7522a..6f710ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,6 +40,11 @@ MESSAGE(STATUS "Building for Fedora")
ADD_DEFINITIONS( -DFEDORA )
ENDIF ( FEDORA)
+IF ( MULTI_SEMANTICS )
+MESSAGE(STATUS "Enabling multi dist support")
+ADD_DEFINITIONS( -DMULTI_SEMANTICS)
+ENDIF ( MULTI_SEMANTICS )
+
FIND_LIBRARY(RPMDB_LIBRARY NAMES rpmdb)
IF ( NOT RPMDB_LIBRARY )
FIND_LIBRARY(RPMDB_LIBRARY NAMES rpm)