summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Schroeder <mls@suse.de>2012-02-02 16:30:41 +0100
committerMichael Schroeder <mls@suse.de>2012-02-02 16:30:41 +0100
commit0589bfb58fca13311e4559bad8b0df1efbc9e3ed (patch)
tree2d32089cc30406d4cae73218049f963cbb16f2c7 /CMakeLists.txt
parent857fe280393400d73dca3f7ca815a815ea9388e0 (diff)
downloadlibsolv-0589bfb58fca13311e4559bad8b0df1efbc9e3ed.tar.gz
libsolv-0589bfb58fca13311e4559bad8b0df1efbc9e3ed.tar.bz2
libsolv-0589bfb58fca13311e4559bad8b0df1efbc9e3ed.zip
- start support for Fedora comps format
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8974388..fd5f75e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ OPTION (USE_VENDORDIRS "Install the bindings in vendor directories?" OFF)
OPTION (ENABLE_RPMDB "Build with rpm database support?" OFF)
OPTION (ENABLE_RPMMD "Build with rpmmd repository support?" OFF)
OPTION (ENABLE_SUSEREPO "Build with suse repository support?" OFF)
+OPTION (ENABLE_COMPS "Build with fedora comps support?" OFF)
OPTION (ENABLE_HELIXREPO "Build with helix repository support?" OFF)
OPTION (ENABLE_DEBIAN "Build with debian database/repository support?" OFF)
@@ -128,7 +129,7 @@ TEST_BIG_ENDIAN (WORDS_BIGENDIAN)
# should create config.h with #cmakedefine instead...
FOREACH (VAR HAVE_STRCHRNUL HAVE_FOPENCOOKIE HAVE_FUNOPEN WORDS_BIGENDIAN
- ENABLE_RPMDB ENABLE_RPMMD ENABLE_SUSEREPO ENABLE_HELIXREPO ENABLE_DEBIAN)
+ ENABLE_RPMDB ENABLE_RPMMD ENABLE_SUSEREPO ENABLE_COMPS ENABLE_HELIXREPO ENABLE_DEBIAN)
IF(${VAR})
ADD_DEFINITIONS (-D${VAR}=1)
ENDIF (${VAR})