summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules73
1 files changed, 0 insertions, 73 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index c9f45ee..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/usr/bin/make -f
-
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-CFLAGS = -Wall
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- MAKEFLAGS += -j$(NUMJOBS)
-endif
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- cp -f /usr/share/misc/config.sub config.sub
- cp -f /usr/share/misc/config.guess config.guess
- CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
- --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
- --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info \
- --enable-shared
- touch $@
-
-build: build-stamp
-build-stamp: configure
- dh_testdir
- $(MAKE)
- $(MAKE) doc
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -rf build-stamp configure-stamp
-# rm -f config.sub config.guess
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
- $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
- rm -f $(CURDIR)/debian/tmp/usr/bin/*_example
- dh_install --fail-missing
-
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
-# dh_installdocs
- dh_installchangelogs
- dh_link
- dh_strip --dbg-package=libijs-dbg
- dh_compress
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps -V "libijs-0.35 (>= 0.35)"
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure