summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@imgtec.com>2018-01-26 15:08:39 +0000
committerEric Engestrom <eric.engestrom@imgtec.com>2018-01-29 15:41:52 +0000
commit1d7bbf852094481a8f514ed786b7a7a8af67e5fe (patch)
treee8390c053121a6ccca2991e7c8027e1cfaafbe32 /meson.build
parentd2b0a4ec70d93040159af0cbc15717d35812ffc5 (diff)
downloadlibdrm-1d7bbf852094481a8f514ed786b7a7a8af67e5fe.tar.gz
libdrm-1d7bbf852094481a8f514ed786b7a7a8af67e5fe.tar.bz2
libdrm-1d7bbf852094481a8f514ed786b7a7a8af67e5fe.zip
always define HAVE_VALGRIND
Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 15a1d405..76a081a9 100644
--- a/meson.build
+++ b/meson.build
@@ -257,16 +257,13 @@ foreach t : [[with_intel, 'INTEL'], [with_vmwgfx, 'VMWGFX'],
[with_vc4, 'VC4'],
[with_freedreno_kgsl, 'FREEDRENO_KGSL'],
[dep_cairo.found(), 'CAIRO'],
+ [dep_valgrind.found(), 'VALGRIND'],
[with_radeon, 'RADEON']]
config.set10('HAVE_@0@'.format(t[1]), t[0])
endforeach
if with_freedreno_kgsl and not with_freedreno
error('cannot enable freedreno-kgsl without freedreno support')
endif
-if dep_valgrind.found()
- config.set10('HAVE_VALGRIND', true)
-endif
-
config.set10('_GNU_SOURCE', true)
config_file = configure_file(
configuration : config,