summaryrefslogtreecommitdiff
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-03 20:33:30 -0700
committerAnas Nashif <anas.nashif@intel.com>2012-11-03 20:33:30 -0700
commitc591394f75d0462d9d9a17d66c1bcf800181a294 (patch)
tree14dded8222a14c5f1f77c27a8c0e1d96ba2ec574 /src/test/Makefile.am
downloadlibcap-ng-c591394f75d0462d9d9a17d66c1bcf800181a294.tar.gz
libcap-ng-c591394f75d0462d9d9a17d66c1bcf800181a294.tar.bz2
libcap-ng-c591394f75d0462d9d9a17d66c1bcf800181a294.zip
Imported Upstream version 0.6.6upstream/0.6.6
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
new file mode 100644
index 0000000..f3963cf
--- /dev/null
+++ b/src/test/Makefile.am
@@ -0,0 +1,28 @@
+# Makefile.am --
+# Copyright 2009,10 Red Hat Inc., Durham, North Carolina.
+# All Rights Reserved.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+# Authors:
+# Steve Grubb <sgrubb@redhat.com>
+#
+
+INCLUDES = -I${top_srcdir} -I${top_srcdir}/src
+check_PROGRAMS = lib_test thread_test
+TESTS = $(check_PROGRAMS)
+
+lib_test_LDADD = ${top_builddir}/src/libcap-ng.la
+thread_test_LDADD = ${top_builddir}/src/libcap-ng.la -lpthread