summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5c13dee..ac90e8b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,14 +1,12 @@
-lib_LTLIBRARIES = libae-0.0.la
-libae_0_0_la_SOURCES = aee.c aee_accessors.c aed.c aee.h aee_accessors.h sz_compat.c
-libae_0_0_la_LDFLAGS = -version-info 0:0
-include_HEADERS = libae.h
+lib_LTLIBRARIES = libaec-0.0.la
+libaec_0_0_la_SOURCES = encode.c encode_accessors.c decode.c encode.h encode_accessors.h sz_compat.c
+libaec_0_0_la_LDFLAGS = -version-info 0:0
+include_HEADERS = libaec.h
-bin_PROGRAMS = encode decode test_szcomp
+bin_PROGRAMS = aec test_szcomp
-encode_LDADD = $(lib_LTLIBRARIES)
-decode_LDADD = $(lib_LTLIBRARIES)
+aec_LDADD = $(lib_LTLIBRARIES)
test_szcomp_LDADD = $(lib_LTLIBRARIES)
-encode_SOURCES = encode.c
-decode_SOURCES = decode.c
+aec_SOURCES = aec.c
test_szcomp_SOURCES = test_szcomp.c