summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c6de7b4
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,13 @@
+noinst_LIBRARIES = libae.a
+libae_a_SOURCES = aee.c aee_mutators.c aed.c sz_compat.c
+include_HEADERS = libae.h
+
+bin_PROGRAMS = encode decode test_szcomp
+
+encode_LDADD = libae.a
+decode_LDADD = libae.a
+test_szcomp_LDADD = libae.a
+
+encode_SOURCES = encode.c
+decode_SOURCES = decode.c
+test_szcomp_SOURCES = test_szcomp.c