summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..e743789
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+AC_PREREQ([2.69])
+AC_INIT([libaes], [0.0.2], [rosenhauer@dkrz.de])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_SRCDIR([src/libae.h])
+AC_CONFIG_HEADERS(config/config.h)
+AM_INIT_AUTOMAKE
+
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_LN_S
+
+# Checks for libraries.
+# FIXME: Replace `main' with a function in `-lae':
+AC_CHECK_LIB([ae], [ae_decode])
+
+# Checks for header files.
+AC_CHECK_HEADERS([inttypes.h stddef.h stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_INLINE
+AC_TYPE_INT64_T
+AC_TYPE_SIZE_T
+AC_TYPE_UINT32_T
+AC_TYPE_UINT64_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([memset strstr])
+
+AC_CONFIG_FILES([Makefile
+ src/Makefile])
+AC_OUTPUT