summaryrefslogtreecommitdiff
path: root/TESTING/LIN/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'TESTING/LIN/CMakeLists.txt')
-rw-r--r--TESTING/LIN/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/TESTING/LIN/CMakeLists.txt b/TESTING/LIN/CMakeLists.txt
index 27ee2659..04a6036f 100644
--- a/TESTING/LIN/CMakeLists.txt
+++ b/TESTING/LIN/CMakeLists.txt
@@ -207,33 +207,33 @@ set(ZLINTSTRFP zchkrfp.f zdrvrfp.f zdrvrf1.f zdrvrf2.f zdrvrf3.f zdrvrf4.f zerrr
macro(add_lin_executable name)
add_executable(${name} ${ARGN})
- target_link_libraries(${name} tmglib ${LAPACK_LIBRARIES})
+ target_link_libraries(${name} tmglib ${LAPACK_LIBRARIES} ${BLAS_LIBRARIES})
endmacro()
if(BUILD_SINGLE)
- add_lin_executable(xlintsts ${ALINTST} ${SCLNTST} ${SLINTST} ${SECOND_SRC})
- add_lin_executable(xlintstrfs ${SLINTSTRFP} ${SECOND_SRC})
+ add_lin_executable(xlintsts ${ALINTST} ${SLINTST} ${SCLNTST})
+ add_lin_executable(xlintstrfs ${SLINTSTRFP})
endif()
if(BUILD_DOUBLE)
- add_lin_executable(xlintstd ${ALINTST} ${DLINTST} ${DZLNTST} ${DSECOND_SRC})
- add_lin_executable(xlintstrfd ${DLINTSTRFP} ${DSECOND_SRC})
+ add_lin_executable(xlintstd ${ALINTST} ${DLINTST} ${DZLNTST})
+ add_lin_executable(xlintstrfd ${DLINTSTRFP})
endif()
if(BUILD_SINGLE AND BUILD_DOUBLE)
- add_lin_executable(xlintstds ${DSLINTST} ${SECOND_SRC} ${DSECOND_SRC})
+ add_lin_executable(xlintstds ${DSLINTST})
endif()
if(BUILD_COMPLEX)
- add_lin_executable(xlintstc ${ALINTST} ${CLINTST} ${SCLNTST} ${SECOND_SRC})
- add_lin_executable(xlintstrfc ${CLINTSTRFP} ${SECOND_SRC})
+ add_lin_executable(xlintstc ${ALINTST} ${CLINTST} ${SCLNTST})
+ add_lin_executable(xlintstrfc ${CLINTSTRFP})
endif()
if(BUILD_COMPLEX16)
- add_lin_executable(xlintstz ${ALINTST} ${ZLINTST} ${DZLNTST} ${DSECOND_SRC})
- add_lin_executable(xlintstrfz ${ZLINTSTRFP} ${DSECOND_SRC})
+ add_lin_executable(xlintstz ${ALINTST} ${ZLINTST} ${DZLNTST})
+ add_lin_executable(xlintstrfz ${ZLINTSTRFP})
endif()
if(BUILD_COMPLEX AND BUILD_COMPLEX16)
- add_lin_executable(xlintstzc ${ZCLINTST} ${SECOND_SRC} ${DSECOND_SRC})
+ add_lin_executable(xlintstzc ${ZCLINTST})
endif()