summaryrefslogtreecommitdiff
path: root/TESTING/MATGEN/CMakeLists.txt
diff options
context:
space:
mode:
authorlangou <julien.langou@ucdenver.edu>2017-02-04 10:04:29 +0100
committerGitHub <noreply@github.com>2017-02-04 10:04:29 +0100
commit48a80fb7cb409d7b9f23c75af03236a35d0e67cd (patch)
tree1cb751c4efcc3239ee9ac642f9b4fc55ff0a830b /TESTING/MATGEN/CMakeLists.txt
parentcabb28f2b07b709c20f18d928cbf054ccb076c24 (diff)
parent44cd01fd33a6aa783e7244bf9ecf236c06d411f7 (diff)
downloadlapack-48a80fb7cb409d7b9f23c75af03236a35d0e67cd.tar.gz
lapack-48a80fb7cb409d7b9f23c75af03236a35d0e67cd.tar.bz2
lapack-48a80fb7cb409d7b9f23c75af03236a35d0e67cd.zip
Merge pull request #119 from turboencabulator/cleanup
Linking fixes
Diffstat (limited to 'TESTING/MATGEN/CMakeLists.txt')
-rw-r--r--TESTING/MATGEN/CMakeLists.txt43
1 files changed, 10 insertions, 33 deletions
diff --git a/TESTING/MATGEN/CMakeLists.txt b/TESTING/MATGEN/CMakeLists.txt
index 54cf9d9e..0fd12df8 100644
--- a/TESTING/MATGEN/CMakeLists.txt
+++ b/TESTING/MATGEN/CMakeLists.txt
@@ -2,33 +2,13 @@
# This is the makefile to create a library of the test matrix
# generators used in LAPACK. The files are organized as follows:
#
-# SCATGEN -- Auxiliary routines called from both REAL and COMPLEX
-# DZATGEN -- Auxiliary routines called from both DOUBLE PRECISION
-# and COMPLEX*16
+# SCATGEN -- Auxiliary routines called from single precision
+# DZATGEN -- Auxiliary routines called from double precision
# SMATGEN -- Single precision real matrix generation routines
# CMATGEN -- Single precision complex matrix generation routines
# DMATGEN -- Double precision real matrix generation routines
# ZMATGEN -- Double precision complex matrix generation routines
#
-# The library can be set up to include routines for any combination
-# of the four precisions. To create or add to the library, enter make
-# followed by one or more of the precisions desired. Some examples:
-# make single
-# make single complex
-# make single double complex complex16
-# Alternatively, the command
-# make
-# without any arguments creates a library of all four precisions.
-# The library is called
-# tmglib.a
-# and is created at the LAPACK directory level.
-#
-# To remove the object files after the library is created, enter
-# make clean
-# On some systems, you can force the source files to be recompiled by
-# entering (for example)
-# make single FRC=FRC
-#
#######################################################################
set(SCATGEN slatm1.f slatm7.f slaran.f slarnd.f)
@@ -51,25 +31,22 @@ set(ZMATGEN zlatms.f zlatme.f zlatmr.f zlatmt.f
zlagge.f zlaghe.f zlagsy.f zlakf2.f zlarge.f zlaror.f zlarot.f
zlatm1.f zlarnd.f zlatm2.f zlatm3.f zlatm5.f zlatm6.f zlahilb.f)
+
+set(SOURCES)
if(BUILD_SINGLE)
- set(ALLOBJ ${SMATGEN} ${SCATGEN})
+ list(APPEND SOURCES ${SMATGEN} ${SCATGEN})
endif()
if(BUILD_DOUBLE)
- set(ALLOBJ ${ALLOBJ} ${DMATGEN} ${DZATGEN})
+ list(APPEND SOURCES ${DMATGEN} ${DZATGEN})
endif()
if(BUILD_COMPLEX)
- set(ALLOBJ ${ALLOBJ} ${CMATGEN} ${SCATGEN})
+ list(APPEND SOURCES ${CMATGEN} ${SCATGEN})
endif()
if(BUILD_COMPLEX16)
- set(ALLOBJ ${ALLOBJ} ${ZMATGEN} ${DZATGEN})
+ list(APPEND SOURCES ${ZMATGEN} ${DZATGEN})
endif()
+list(REMOVE_DUPLICATES SOURCES)
-if(NOT ALLOBJ)
- set(ALLOBJ ${SMATGEN} ${CMATGEN} ${SCATGEN} ${DMATGEN} ${ZMATGEN}
- ${DZATGEN})
-else()
- list(REMOVE_DUPLICATES ALLOBJ)
-endif()
-add_library(tmglib ${ALLOBJ})
+add_library(tmglib ${SOURCES})
target_link_libraries(tmglib ${LAPACK_LIBRARIES})
lapack_install_library(tmglib)