summaryrefslogtreecommitdiff
path: root/TESTING/CMakeLists.txt
diff options
context:
space:
mode:
authorjulie <julielangou@users.noreply.github.com>2014-06-14 17:04:05 +0000
committerjulie <julielangou@users.noreply.github.com>2014-06-14 17:04:05 +0000
commit54a506304c4b81e8f2ce03a11356e25b74688b4c (patch)
tree11344f8dd9c419e2f69ab9811a3a265e039435e0 /TESTING/CMakeLists.txt
parentb42e9d5b6fc5484913ab098b5c0bc24b89e51d24 (diff)
downloadlapack-54a506304c4b81e8f2ce03a11356e25b74688b4c.tar.gz
lapack-54a506304c4b81e8f2ce03a11356e25b74688b4c.tar.bz2
lapack-54a506304c4b81e8f2ce03a11356e25b74688b4c.zip
Applied patch provided from vitaut on LAPACK forum on June 13th.
The patch fixes the warnings (Policy CMP0026) by replacing the deprecated LOCATION target property with the generator expression $<TARGET_FILE> See http://icl.cs.utk.edu/lapack-forum/viewtopic.php?f=13&t=4556&p=10939#p10939
Diffstat (limited to 'TESTING/CMakeLists.txt')
-rw-r--r--TESTING/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/TESTING/CMakeLists.txt b/TESTING/CMakeLists.txt
index 9025a98d..203ad517 100644
--- a/TESTING/CMakeLists.txt
+++ b/TESTING/CMakeLists.txt
@@ -10,12 +10,11 @@ add_subdirectory(EIG)
macro(add_lapack_test output input target)
set(TEST_INPUT "${LAPACK_SOURCE_DIR}/TESTING/${input}")
set(TEST_OUTPUT "${LAPACK_BINARY_DIR}/TESTING/${output}")
- get_target_property(TEST_LOC ${target} LOCATION)
string(REPLACE "." "_" input_name ${input})
set(testName "${target}_${input_name}")
if(EXISTS "${TEST_INPUT}")
- add_test(LAPACK-${testName} "${CMAKE_COMMAND}"
- -DTEST=${TEST_LOC}
+ add_test(NAME LAPACK-${testName} COMMAND "${CMAKE_COMMAND}"
+ -DTEST=$<TARGET_FILE:${target}>
-DINPUT=${TEST_INPUT}
-DOUTPUT=${TEST_OUTPUT}
-DINTDIR=${CMAKE_CFG_INTDIR}