summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-12 11:48:21 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-12 14:21:22 -0200
commit904b57d022b0187bc5c6eeeacf2d5bf566ca8881 (patch)
tree865e2a67b9adedb4914005ddba919d004c9c6e90 /man/Makefile.am
parent5b24df2ffc7673520331ee4b0c592065bd116733 (diff)
downloadkmod-904b57d022b0187bc5c6eeeacf2d5bf566ca8881.tar.gz
kmod-904b57d022b0187bc5c6eeeacf2d5bf566ca8881.tar.bz2
kmod-904b57d022b0187bc5c6eeeacf2d5bf566ca8881.zip
build-sys: build man pages
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..c689178
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,13 @@
+MAN5 = depmod.d.5
+MAN8 =
+
+dist_man_MANS = $(MAN5) $(MAN8)
+
+EXTRA_DIST = $(MAN5:%.5=%.xml) $(MAN8:%.8=%.xml)
+XSLTPROC_FLAGS = \
+ --nonet \
+ --param funcsynopsis.style "'ansi'"
+
+%.5 %.8: %.xml
+ $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_FLAGS) \
+ http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<