summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichal Marek <mmarek@suse.cz>2014-04-04 11:30:07 +0200
committerMichal Marek <mmarek@suse.cz>2014-04-04 13:06:05 +0200
commit9324bb52f30cb6d0ff2828e1a63056d9c78960a1 (patch)
tree5445741c3a6b76e7609e30eeb9dbe2490330e8ce /Makefile.am
parent81bf88d6c4a6897ae2700cd5fd4f801906c96f33 (diff)
downloadkmod-9324bb52f30cb6d0ff2828e1a63056d9c78960a1.tar.gz
kmod-9324bb52f30cb6d0ff2828e1a63056d9c78960a1.tar.bz2
kmod-9324bb52f30cb6d0ff2828e1a63056d9c78960a1.zip
testsuite: Warn if sysconfdir is not /etc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e65fdfb..199588c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -213,7 +213,14 @@ TESTSUITE_OVERRIDE_LIBS = testsuite/uname.la testsuite/path.la \
TESTSUITE_OVERRIDE_LIBS_LDFLAGS = avoid-version -module -shared -export-dynamic \
-rpath /nowhere -ldl
-check-am: rootfs
+check-sysconfdir:
+ $(AM_V_at)if test "$(sysconfdir)" != "/etc" -a "$(sysconfdir)" != "/etc/"; then \
+ echo "warning: Some tests will fail without --sysconfdir=/etc" >&2; \
+ fi
+.PHONY: check-sysconfdir
+
+check-am: rootfs check-sysconfdir
+
check_LTLIBRARIES = $(TESTSUITE_OVERRIDE_LIBS)