summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@intel.com>2013-07-30 03:47:19 -0300
committerLucas De Marchi <lucas.demarchi@intel.com>2013-07-30 14:45:21 -0300
commit80cf2c8f05813b04a5479746ce3ddaef00ea240d (patch)
treef77029e4b4cd1f3587c982f02d73a420ac3fd39f /Makefile.am
parentec6d026f26af3bc76365f2a40da758248d849809 (diff)
downloadkmod-80cf2c8f05813b04a5479746ce3ddaef00ea240d.tar.gz
kmod-80cf2c8f05813b04a5479746ce3ddaef00ea240d.tar.bz2
kmod-80cf2c8f05813b04a5479746ce3ddaef00ea240d.zip
build: Install bash completion data
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 57b7372..91a766a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -89,6 +89,10 @@ pkgconfig_DATA = libkmod/libkmod.pc
EXTRA_DIST += libkmod/libkmod.pc.in
CLEANFILES += libkmod/libkmod.pc
+bashcompletiondir=@bashcompletiondir@
+dist_bashcompletion_DATA = \
+ shell-completion/bash/kmod
+
install-exec-hook:
if test "$(libdir)" != "$(rootlibdir)"; then \
$(MKDIR_P) $(DESTDIR)$(rootlibdir) && \
@@ -207,7 +211,8 @@ testsuite-distclean:
DISTCLEAN_LOCAL_HOOKS += testsuite-distclean
EXTRA_DIST += testsuite/rootfs-pristine
-DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc --sysconfdir=/etc --with-zlib
+DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc --sysconfdir=/etc --with-zlib \
+ --with-bashcompletiondir=$$dc_install_base/$(bashcompletiondir)
distclean-local: $(DISTCLEAN_LOCAL_HOOKS)