summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@kernel.org>2019-02-20 14:22:04 +0200
committerLucas De Marchi <lucas.demarchi@intel.com>2019-02-20 10:38:56 -0800
commitf8b8d7b330433511d19a936ddfc7b7d1af5490b5 (patch)
treeae13b2adba555f9d428818079edf849f640f512d /Makefile.am
parent8e266b9eeffa3c1fc4dca0081c0553f8c2a488c0 (diff)
downloadkmod-f8b8d7b330433511d19a936ddfc7b7d1af5490b5.tar.gz
kmod-f8b8d7b330433511d19a936ddfc7b7d1af5490b5.tar.bz2
kmod-f8b8d7b330433511d19a936ddfc7b7d1af5490b5.zip
build: Stop using dolt
This does regress "make -12" from 0.7s to 0.9s on my Coffee Lake machine, but even on slower hardware this will not amount to a noticable slowdown. On the other hand using dolt can create problems for people doing cross-compilation, e.g. Yocto has two hacks just for dolt in kmod: https://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes-kernel/kmod/kmod.inc?id=a17abae00785c76cfffe5381a22fb2c86b982e82 (Lucas: remove leftover entry in Makefile and reformat commit message)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 758f4f0..c5c2f06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -415,8 +415,6 @@ distclean-local: $(DISTCLEAN_LOCAL_HOOKS)
buildtest-TESTS:
$(MAKE) $(AM_MAKEFLAGS) $(check_LTLIBRARIES) $(check_PROGRAMS)
-DISTCLEANFILES += $(DOLT_CLEANFILES)
-
# ------------------------------------------------------------------------------
# coverage
# ------------------------------------------------------------------------------