summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2013-04-16 22:39:55 +0200
committerLucas De Marchi <lucas.de.marchi@gmail.com>2013-04-16 23:10:36 -0300
commitdb6f2fc7e1152fb9aee8530e85c40bf514457aa4 (patch)
tree15c726b600d2e4b20b49e4590723d86bbb7c9266 /Makefile.am
parenta20a37c351a2197992b277cee4c3209d45cbe065 (diff)
downloadkmod-db6f2fc7e1152fb9aee8530e85c40bf514457aa4.tar.gz
kmod-db6f2fc7e1152fb9aee8530e85c40bf514457aa4.tar.bz2
kmod-db6f2fc7e1152fb9aee8530e85c40bf514457aa4.zip
tools: add static-nodes tool
This tool reads modules.devname from the current kernel directory and outputs the information. By default in a human-readable format, and optionally in machine-readable formats. For now only the tmpfiles.d(5) format is supported, but more could easily be added in the future if there is a need. This means nothing but kmod needs to reads the private files under /lib/modules/. In particular systemd-udevd can stop reading modules.devname. Tools that used to read /lib/modules/`uname -r`/modules.devname directly, can now move to reading 'kmod static-nodes devname'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fe4c769..b1bfd59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -110,7 +110,8 @@ noinst_SCRIPTS = tools/insmod tools/rmmod tools/lsmod \
tools_kmod_SOURCES = tools/kmod.c tools/kmod.h tools/lsmod.c \
tools/rmmod.c tools/insmod.c \
tools/modinfo.c tools/modprobe.c \
- tools/depmod.c tools/log.h tools/log.c
+ tools/depmod.c tools/log.h tools/log.c \
+ tools/static-nodes.c
tools_kmod_LDADD = libkmod/libkmod-util.la \
libkmod/libkmod.la