summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@intel.com>2015-02-03 05:17:49 -0200
committerLucas De Marchi <lucas.demarchi@intel.com>2015-02-03 05:19:38 -0200
commit0e68c6258ef802c0e67a69921f5c23a3caa1c70f (patch)
tree16d3fd5a0e217d3b15417adeee0d1de5ffb08370 /Makefile.am
parent450c1f037b3fe3dad49c94918228d6436940e75f (diff)
downloadkmod-0e68c6258ef802c0e67a69921f5c23a3caa1c70f.tar.gz
kmod-0e68c6258ef802c0e67a69921f5c23a3caa1c70f.tar.bz2
kmod-0e68c6258ef802c0e67a69921f5c23a3caa1c70f.zip
build: let touch on directory as last step
We need to let these instructions in kmod to be the last executed ones. Otherwise the subdirectory containing the modules could propagate up the time access.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7774759..a99a5a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,10 +215,10 @@ ROOTFS = testsuite/rootfs
ROOTFS_PRISTINE = $(top_srcdir)/testsuite/rootfs-pristine
CREATE_ROOTFS = $(AM_V_GEN) ( $(RM) -rf $(ROOTFS) && mkdir -p $(dir $(ROOTFS)) && \
cp -r $(ROOTFS_PRISTINE) $(ROOTFS) && \
- touch testsuite/stamp-rootfs && \
find $(ROOTFS) -type d -exec chmod +w {} \; && \
$(top_srcdir)/testsuite/populate-modules.sh \
- $(MODULE_PLAYGROUND) $(ROOTFS) )
+ $(MODULE_PLAYGROUND) $(ROOTFS) ) && \
+ touch testsuite/stamp-rootfs
build-module-playground:
$(AM_V_GEN)if test "$(top_srcdir)" != "$(top_builddir)"; then \