summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYauheni Kaliuta <yauheni.kaliuta@redhat.com>2017-02-22 11:41:58 +0200
committerLucas De Marchi <lucas.demarchi@intel.com>2017-02-22 04:50:22 -0800
commit9be03c52ccae073745f46e857296f2c21be10e03 (patch)
tree44221480121ab032c07e9c14781abb1f468eb070 /Makefile.am
parent31dd40a6b8fd66127496fc0772b6dbe0a3e5b823 (diff)
downloadkmod-9be03c52ccae073745f46e857296f2c21be10e03.tar.gz
kmod-9be03c52ccae073745f46e857296f2c21be10e03.tar.bz2
kmod-9be03c52ccae073745f46e857296f2c21be10e03.zip
testsuite: depmod: check netsted loops reporting
The patch adds nested loops configuration for the loop test: mod-loop-h -> mod-loop-i -> mod-loop-j -> mod-loop-k ^ | | --------------------------- | | | ------------------------------------------- making 2 loops with common edges: mod-loop-h -> mod-loop-i -> mod-loop-j -> mod-loop-h mod-loop-h -> mod-loop-i -> mod-loop-j -> mod-loop-k -> mod-loop-h The actual output for the loops is: depmod: ERROR: Cycle detected: mod_loop_h -> mod_loop_h depmod: ERROR: Cycle detected: mod_loop_i -> mod_loop_j -> mod_loop_k -> mod_loop_h -> mod_loop_i (the order in the second doesn't matter, but the first one is incorrect) Signed-off-by: Yauheni Kaliuta <yauheni.kaliuta@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 981a1af..76262bb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -287,6 +287,10 @@ EXTRA_DIST += \
testsuite/module-playground/mod-loop-e.c \
testsuite/module-playground/mod-loop-f.c \
testsuite/module-playground/mod-loop-g.c \
+ testsuite/module-playground/mod-loop-h.c \
+ testsuite/module-playground/mod-loop-i.c \
+ testsuite/module-playground/mod-loop-j.c \
+ testsuite/module-playground/mod-loop-k.c \
testsuite/module-playground/mod-loop.h \
testsuite/module-playground/mod-simple.c \
testsuite/module-playground/mod-simple-i386.ko \