summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2fbdd6d..8264457 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ dist_json_DATA = $(wildcard $(srcdir)/data/*.json)
# the common Makefile snippet
# and the markdown documentation currently not handled
# by automake
-EXTRA_DIST = bin bootstrap common.mk README.md
+EXTRA_DIST = bin bootstrap common.mk README.md ChangeLog.md
DISTCLEANFILES = $(pkgconfig_DATA)
@@ -22,6 +22,13 @@ pot:
cd $$domain && make $$domain.pot && cd ..; \
done
+# Updates all xml files
+.PHONY: xml
+xml:
+ for domain in $(DOMAINS); do \
+ cd $$domain && make $$domain.xml && cd ..; \
+ done
+
.PHONY: release
release: update-po check distcheck