summaryrefslogtreecommitdiff
path: root/src/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/Makefile.am')
-rw-r--r--src/tools/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/tools/Makefile.am b/src/tools/Makefile.am
new file mode 100644
index 0000000..8074eea
--- /dev/null
+++ b/src/tools/Makefile.am
@@ -0,0 +1,27 @@
+bin_PROGRAMS=analyze chmorph hunspell munch unmunch hzip hunzip
+
+INCLUDES=-I${top_srcdir}/src/hunspell -I${top_srcdir}/src/parsers
+
+hzip_SOURCES=hzip.c
+hunzip_SOURCES=hunzip.cxx
+hunzip_LDADD = ../hunspell/libhunspell-1.3.la
+
+munch_SOURCES=munch.c munch.h
+unmunch_SOURCES=unmunch.c unmunch.h
+
+example_SOURCES=example.cxx
+example_LDADD = ../hunspell/libhunspell-1.3.la
+
+hunspell_SOURCES=hunspell.cxx
+hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
+ ../hunspell/libhunspell-1.3.la @CURSESLIB@ @READLINELIB@
+
+analyze_SOURCES=analyze.cxx
+analyze_LDADD = ../hunspell/libhunspell-1.3.la
+
+chmorph_SOURCES=chmorph.cxx
+chmorph_LDADD = ../parsers/libparsers.a ../hunspell/libhunspell-1.3.la
+
+noinst_PROGRAMS=example
+
+dist_bin_SCRIPTS=makealias affixcompress wordforms ispellaff2myspell wordlist2hunspell