summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
new file mode 100644
index 0000000..4b3b3d5
--- /dev/null
+++ b/tools/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required (VERSION 3.2.2)
+PROJECT (HDF5_TOOLS)
+
+#-----------------------------------------------------------------------------
+# Apply Definitions to compiler in this directory and below
+#-----------------------------------------------------------------------------
+add_definitions (${HDF_EXTRA_C_FLAGS})
+
+# --------------------------------------------------------------------
+# If testing was NOT enabled, then we need to build the tools library
+# --------------------------------------------------------------------
+if (NOT BUILD_TESTING)
+ add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/lib)
+endif ()
+
+#-----------------------------------------------------------------------------
+# Setup include Directories
+#-----------------------------------------------------------------------------
+INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
+
+#-- Add the test sources
+add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/src)
+
+#-- Add the tests
+if (BUILD_TESTING)
+ add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/test)
+endif ()