summaryrefslogtreecommitdiff
path: root/hl/c++/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hl/c++/CMakeLists.txt')
-rw-r--r--hl/c++/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/hl/c++/CMakeLists.txt b/hl/c++/CMakeLists.txt
new file mode 100644
index 0000000..91bfa14
--- /dev/null
+++ b/hl/c++/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required (VERSION 3.2.2)
+PROJECT (HDF5_HL_CPP)
+
+#-----------------------------------------------------------------------------
+# Main HL lib is in /src
+#-----------------------------------------------------------------------------
+add_subdirectory (${HDF5_HL_CPP_SOURCE_DIR}/src ${HDF5_HL_CPP_BINARY_DIR}/src)
+
+# --------------------------------------------------------------------
+# Add in the examples for the Packet Table codes
+# --------------------------------------------------------------------
+if (HDF5_BUILD_EXAMPLES)
+ add_subdirectory (${HDF5_HL_CPP_SOURCE_DIR}/examples ${HDF5_HL_CPP_BINARY_DIR}/examples)
+endif ()
+
+# --------------------------------------------------------------------
+# Add in the unit tests for the packet table c++ wrapper
+# --------------------------------------------------------------------
+
+if (BUILD_TESTING)
+ add_subdirectory (${HDF5_HL_CPP_SOURCE_DIR}/test ${HDF5_HL_CPP_BINARY_DIR}/test)
+endif ()