summaryrefslogtreecommitdiff
path: root/hl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hl/CMakeLists.txt')
-rw-r--r--hl/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/hl/CMakeLists.txt b/hl/CMakeLists.txt
new file mode 100644
index 0000000..a47e023
--- /dev/null
+++ b/hl/CMakeLists.txt
@@ -0,0 +1,32 @@
+cmake_minimum_required (VERSION 3.2.2)
+PROJECT (HDF5_HL C CXX)
+
+#-----------------------------------------------------------------------------
+# Apply Definitions to compiler in this directory and below
+#-----------------------------------------------------------------------------
+add_definitions (${HDF_EXTRA_C_FLAGS})
+
+
+#-----------------------------------------------------------------------------
+# List Source files
+#-----------------------------------------------------------------------------
+INCLUDE_DIRECTORIES (${HDF5_HL_SOURCE_DIR}/src )
+
+add_subdirectory (${HDF5_HL_SOURCE_DIR}/src ${HDF5_HL_BINARY_DIR}/src)
+
+#-- Build the High level Tools
+if (HDF5_BUILD_TOOLS)
+ add_subdirectory (${HDF5_HL_SOURCE_DIR}/tools ${HDF5_HL_BINARY_DIR}/tools)
+endif ()
+
+#-- Add High Level Examples
+if (HDF5_BUILD_EXAMPLES)
+ add_subdirectory (${HDF5_HL_SOURCE_DIR}/examples ${HDF5_HL_BINARY_DIR}/examples)
+endif ()
+
+#-- Build the Unit testing if requested
+if (NOT HDF5_EXTERNALLY_CONFIGURED)
+ if (BUILD_TESTING)
+ add_subdirectory (${HDF5_HL_SOURCE_DIR}/test ${HDF5_HL_BINARY_DIR}/test)
+ endif ()
+endif ()