summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJussi Laako <jussi.laako@linux.intel.com>2014-05-19 16:56:06 +0300
committerJussi Laako <jussi.laako@linux.intel.com>2014-05-19 18:00:54 +0300
commit13d386cfa5afaaa04af763c16cb4d6292fac5d02 (patch)
tree37b570364dabf06a22269a217622dc90de813249 /Makefile.am
downloadgsignond-13d386cfa5afaaa04af763c16cb4d6292fac5d02.tar.gz
gsignond-13d386cfa5afaaa04af763c16cb4d6292fac5d02.tar.bz2
gsignond-13d386cfa5afaaa04af763c16cb4d6292fac5d02.zip
Initial package import after relocation from IVI profile
Change-Id: I8ffdf9b96963059b4e9a20b05856f1dd14b8130f
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3015bb7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,51 @@
+ACLOCAL_AMFLAGS = -I m4
+
+# --enable-distcheck is here to make it possible to use
+# also --enable-dbus-type=session here
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-debug \
+ --enable-gtk-doc \
+ --enable-distcheck
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gsignond.pc
+
+sysconf_DATA = gsignond.conf
+
+SUBDIRS = src test docs
+
+EXTRA_DIST = dists tools
+
+valgrind:
+ cd test; make valgrind
+
+dist-hook:
+ @echo
+ @echo "==== Run 'make update-online-doc' to update online documentation ===="
+ @echo
+
+update-online-doc:
+ @tar zxf $(PACKAGE)-$(VERSION).tar.gz && \
+ pushd . > /dev/null && \
+ cd .. && \
+ git clone https://code.google.com/p/accounts-sso.gsignon-docs/ ; \
+ cd accounts-sso.gsignon-docs && \
+ git pull ; \
+ mkdir -p $(PACKAGE) && \
+ rm -rf $(PACKAGE)/* && \
+ popd > /dev/null && \
+ cp -rf $(PACKAGE)-$(VERSION)/docs/html/* ../accounts-sso.gsignon-docs/$(PACKAGE)/ && \
+ pushd . > /dev/null && \
+ cd ../accounts-sso.gsignon-docs && \
+ git add $(PACKAGE)/* && \
+ git commit -m "Updated documentation for $(PACKAGE) to version $(VERSION)" && \
+ git push ; \
+ popd > /dev/null && \
+ rm -rf $(PACKAGE)-$(VERSION)
+
+lcov: check
+ @rm -rf lcov-report
+ @lcov -c --directory src/ --output-file lcov.output
+ @genhtml lcov.output --output-directory lcov-report
+ @rm lcov.output
+ @echo "Coverage report is in file://$(abs_srcdir)/lcov-report/index.html"