summaryrefslogtreecommitdiff
path: root/tests/gpg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gpg/Makefile.am')
-rw-r--r--tests/gpg/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/gpg/Makefile.am b/tests/gpg/Makefile.am
index b50f4b0..ba2d1f3 100644
--- a/tests/gpg/Makefile.am
+++ b/tests/gpg/Makefile.am
@@ -22,7 +22,8 @@
GPG = gpg
GPG_AGENT = gpg-agent
-TESTS_ENVIRONMENT = GNUPGHOME=$(abs_builddir) LC_ALL=C GPG_AGENT_INFO= \
+GNUPGHOME=$(abs_builddir)
+TESTS_ENVIRONMENT = GNUPGHOME=$(GNUPGHOME) LC_ALL=C GPG_AGENT_INFO= \
top_srcdir=$(top_srcdir)
# The keylist tests must come after the import and the edit test.
@@ -104,5 +105,11 @@ gpg.conf:
echo no-force-v3-sigs > ./gpg.conf
gpg-agent.conf:
-# This is required for gpg2, which does not support command fd.
+# This is required for gpg2, which does not support command fd for the
+# passphrase. disable-scdaemon is required so that we don't try using
+# a key from a smartcard reader (error might be: Unusable secret key)
echo pinentry-program $(abs_srcdir)/pinentry > ./gpg-agent.conf
+ echo disable-scdaemon >> ./gpg-agent.conf
+
+
+# end-of-file