summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..93afc06
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,36 @@
+# doc - Automake template
+# Copyright (C) 2001, 2004 g10 Code GmbH
+#
+# This file is part of GPGME.
+#
+# GPGME is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# GPGME is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General
+# Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+
+## Process this file with automake to produce Makefile.in
+
+DISTCLEANFILES = gpgme.tmp
+
+EXTRA_DIST = module-overview.sk HACKING ChangeLog-2011
+
+info_TEXINFOS = gpgme.texi
+gpgme_TEXINFOS = uiserver.texi lesser.texi gpl.texi
+
+online: gpgme.html gpgme.pdf
+ set -e; \
+ echo "Uploading current manuals to www.gnupg.org ..."; \
+ user=werner ; \
+ (cd gpgme.html && rsync -vr --exclude='.svn' . \
+ $${user}@cvs.gnupg.org:webspace/manuals/gpgme/ ); \
+ rsync -v gpgme.pdf $${user}@cvs.gnupg.org:webspace/manuals/
+