summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 32 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 43b18f6..9d696b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,8 +31,8 @@ min_automake_version="1.14"
# for the LT versions.
m4_define([mym4_package],[gpgme])
m4_define([mym4_major], [1])
-m4_define([mym4_minor], [17])
-m4_define([mym4_micro], [1])
+m4_define([mym4_minor], [18])
+m4_define([mym4_micro], [0])
# Below is m4 magic to extract and compute the git revision number,
# the decimalized short revision number, a beta version string and a
@@ -53,19 +53,19 @@ AC_INIT([mym4_package],[mym4_version],[https://bugs.gnupg.org])
# (Interfaces added: AGE++)
# (Interfaces removed: AGE=0)
#
-LIBGPGME_LT_CURRENT=37
-LIBGPGME_LT_AGE=26
+LIBGPGME_LT_CURRENT=38
+LIBGPGME_LT_AGE=27
LIBGPGME_LT_REVISION=0
# If there is an ABI break in gpgmepp or qgpgme also bump the
# version in IMPORTED_LOCATION in the GpgmeppConfig-w32.cmake.in.in
-LIBGPGMEPP_LT_CURRENT=20
-LIBGPGMEPP_LT_AGE=14
+LIBGPGMEPP_LT_CURRENT=21
+LIBGPGMEPP_LT_AGE=15
LIBGPGMEPP_LT_REVISION=0
-LIBQGPGME_LT_CURRENT=15
-LIBQGPGME_LT_AGE=0
+LIBQGPGME_LT_CURRENT=16
+LIBQGPGME_LT_AGE=1
LIBQGPGME_LT_REVISION=0
################################################
@@ -331,8 +331,6 @@ for language in $enabled_languages; do
fi
done
-
-
# Enable C++ 11 if cpp language is requested
LIST_MEMBER("cpp", $enabled_languages)
if test "$found" = "1"; then
@@ -354,6 +352,16 @@ if test "$found" = "1"; then
fi
fi
+# Check whether compiler supports visibility attribute (if cpp language is enabled)
+LIST_MEMBER("cpp", $enabled_languages)
+if test "$found" = "1"; then
+ AX_GCC_FUNC_ATTRIBUTE(visibility)
+ if test "$ax_cv_have_func_attribute_visibility" = "yes"; then
+ GPGME_CPP_CFLAGS="$GPGME_CPP_CFLAGS -fvisibility=hidden"
+ fi
+fi
+AC_SUBST(GPGME_CPP_CFLAGS)
+
# Check that if qt is enabled cpp also is enabled
LIST_MEMBER("qt", $enabled_languages)
if test "$found" = "1"; then
@@ -394,6 +402,16 @@ if test "$found" = "1"; then
fi
fi
fi
+
+# Check if compiler supports visibility attribute (if qt is enabled)
+LIST_MEMBER("qt", $enabled_languages)
+if test "$found" = "1"; then
+ AX_GCC_FUNC_ATTRIBUTE(visibility)
+ if test "$ax_cv_have_func_attribute_visibility" = "yes"; then
+ GPGME_QT_CFLAGS="$GPGME_QT_CFLAGS -fvisibility=hidden"
+ fi
+fi
+
AM_CONDITIONAL([HAVE_DOXYGEN],
[test -n "$DOXYGEN"])
if test -n "$GRAPHVIZ"; then
@@ -706,6 +724,9 @@ AM_PATH_GPG_ERROR("$NEED_GPG_ERROR_VERSION",
AC_DEFINE(GPG_ERR_SOURCE_DEFAULT, GPG_ERR_SOURCE_GPGME,
[The default error source for GPGME.])
+AM_CONDITIONAL(USE_GPGRT_CONFIG, [test -n "$GPGRT_CONFIG" \
+ -a "$ac_cv_path_GPG_ERROR_CONFIG" = no])
+
# And for libassuan.
have_libassuan=no
AM_PATH_LIBASSUAN("$NEED_LIBASSUAN_API:$NEED_LIBASSUAN_VERSION",
@@ -721,7 +742,7 @@ fi
#
# Check for getgid etc
-AC_CHECK_FUNCS(getgid getegid closefrom)
+AC_CHECK_FUNCS(getgid getegid closefrom nanosleep)
# Replacement functions.