summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2013-02-19 08:22:18 -0800
committerAnas Nashif <anas.nashif@intel.com>2013-02-19 08:22:18 -0800
commit26fb537f9cf011eaeaf975adcad5e8e9154d04fd (patch)
treeddc2171273fca8b730b9c496e1b5ed3b01878577 /tests/Makefile.am
downloadgpgme-26fb537f9cf011eaeaf975adcad5e8e9154d04fd.tar.gz
gpgme-26fb537f9cf011eaeaf975adcad5e8e9154d04fd.tar.bz2
gpgme-26fb537f9cf011eaeaf975adcad5e8e9154d04fd.zip
Imported Upstream version 1.3.2upstream/1.3.2
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..0ecdab2
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,51 @@
+# Makefile.am - Makefile for GPGME tests.
+# Copyright (C) 2000 Werner Koch (dd9jn)
+# Copyright (C) 2001, 2004 g10 Code GmbH
+#
+# This file is part of GPGME.
+#
+# GPGME is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# GPGME is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General
+# Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in
+
+TESTS_ENVIRONMENT = GNUPGHOME=$(abs_builddir)
+
+TESTS = t-version t-data t-engine-info
+
+EXTRA_DIST = t-data-1.txt t-data-2.txt ChangeLog-2011
+
+INCLUDES = -I$(top_builddir)/src
+
+AM_CPPFLAGS = @GPG_ERROR_CFLAGS@
+LDADD = ../src/libgpgme.la @GPG_ERROR_LIBS@
+
+noinst_HEADERS = run-support.h
+
+noinst_PROGRAMS = $(TESTS) run-keylist run-export run-import run-sign \
+ run-verify
+
+
+if RUN_GPG_TESTS
+gpgtests = gpg
+else
+gpgtests =
+endif
+
+if RUN_GPGSM_TESTS
+gpgsmtests = gpgsm opassuan
+else
+gpgsmtests =
+endif
+
+SUBDIRS = ${gpgtests} ${gpgsmtests}