summaryrefslogtreecommitdiff
path: root/lang/python/tests/Makefile.am
diff options
context:
space:
mode:
authorJinWang An <jinwang.an@samsung.com>2021-12-01 16:54:36 +0900
committerJinWang An <jinwang.an@samsung.com>2021-12-01 16:54:36 +0900
commit214479142a766516e8770c3e1a3b0b0cc37c239e (patch)
tree43ff2d595b2e19d2f3e35ce6cf74a9e4a63ab3e7 /lang/python/tests/Makefile.am
parent3a4efa5aa27f73c93a1b020b8b30f07f0b4e46c7 (diff)
downloadgpgme-99c6dc5d2c80ae6918702e902f93b1d4b7e735f7.tar.gz
gpgme-99c6dc5d2c80ae6918702e902f93b1d4b7e735f7.tar.bz2
gpgme-99c6dc5d2c80ae6918702e902f93b1d4b7e735f7.zip
Imported Upstream version 1.9.0upstream/1.9.0
Diffstat (limited to 'lang/python/tests/Makefile.am')
-rw-r--r--lang/python/tests/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/python/tests/Makefile.am b/lang/python/tests/Makefile.am
index 39f532c..9c19a13 100644
--- a/lang/python/tests/Makefile.am
+++ b/lang/python/tests/Makefile.am
@@ -46,11 +46,16 @@ py_tests = t-wrapper.py \
t-trustlist.py \
t-edit.py \
t-keylist.py \
+ t-keylist-from-data.py \
t-wait.py \
t-encrypt-large.py \
t-file-name.py \
t-idiomatic.py \
- t-protocol-assuan.py
+ t-protocol-assuan.py \
+ t-quick-key-creation.py \
+ t-quick-subkey-creation.py \
+ t-quick-key-manipulation.py \
+ t-quick-key-signing.py
XTESTS = initial.py $(py_tests) final.py
EXTRA_DIST = support.py $(XTESTS) encrypt-only.asc sign-only.asc \
@@ -73,7 +78,7 @@ xcheck: ./pubring-stamp
CLEANFILES = secring.gpg pubring.gpg pubring.kbx trustdb.gpg dirmngr.conf \
gpg-agent.conf pubring.kbx~ gpg.conf pubring.gpg~ \
- random_seed .gpg-v21-migrated \
+ random_seed .gpg-v21-migrated tofu.db \
pubring-stamp private-keys-v1.d/gpg-sample.stamp
private_keys = \
@@ -107,8 +112,9 @@ clean-local:
./gpg.conf:
# This is required for t-sig-notations.
echo no-force-v3-sigs > ./gpg.conf
+ echo ignore-invalid-option agent-program >> ./gpg.conf
+ echo "agent-program `which $(GPG_AGENT)`|--debug-quick-random" >> ./gpg.conf
./gpg-agent.conf:
# This is required for gpg2, which does not support command fd.
echo pinentry-program $(abs_top_srcdir)/tests/gpg/pinentry >$@
- echo allow-loopback-pinentry >>$@