summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
author <shinichiro.hamaji@gmail.com>2009-04-22 04:28:59 +0000
committer <shinichiro.hamaji@gmail.com>2009-04-22 04:28:59 +0000
commit94a3b0ed4f24c15b20c66aeeeff918c5f80a484c (patch)
tree54d85fdab730689d542a326ec94d5e3f014222ae /configure.ac
parentca448a53a0afff771fa328348802782c538f38ae (diff)
downloadglog-94a3b0ed4f24c15b20c66aeeeff918c5f80a484c.tar.gz
glog-94a3b0ed4f24c15b20c66aeeeff918c5f80a484c.tar.bz2
glog-94a3b0ed4f24c15b20c66aeeeff918c5f80a484c.zip
Add -lgflags into LD_FLAGS when gflags is detected and --with-gflags isn't specified. Thanks kzk for this patch!
git-svn-id: https://google-glog.googlecode.com/svn/trunk@49 eb4d4688-79bd-11dd-afb4-1d65580434c0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e87cee..60466df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,6 +110,9 @@ AC_ARG_WITH(gflags, AS_HELP_STRING[--with-gflags=GFLAGS_DIR],
AC_CHECK_LIB(gflags, main, ac_cv_have_libgflags=1, ac_cv_have_libgflags=0)
if test x"$ac_cv_have_libgflags" = x"1"; then
AC_DEFINE(HAVE_LIB_GFLAGS, 1, [define if you have google gflags library])
+ if test x"$GFLAGS_LIBS" = x""; then
+ GFLAGS_LIBS="-lgflags"
+ fi
else
GFLAGS_CFLAGS=
GFLAGS_LIBS=