summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
author <shinichiro.hamaji@gmail.com>2008-10-17 11:52:32 +0000
committer <shinichiro.hamaji@gmail.com>2008-10-17 11:52:32 +0000
commit364832195d0d333910cf63cf98ac16fdb82ebd55 (patch)
treed4dcb03dbb3a5e2d7025d89dc015d6205d0bd765 /configure.ac
parente1fb8f60e9922765d5693a3e219c8d416b6c514f (diff)
downloadglog-364832195d0d333910cf63cf98ac16fdb82ebd55.tar.gz
glog-364832195d0d333910cf63cf98ac16fdb82ebd55.tar.bz2
glog-364832195d0d333910cf63cf98ac16fdb82ebd55.zip
Use dladdr to get symbols for environments which doesn't use ELF and
has execinfo.h (e.g., MacOSX 10.5). Though dladdr may not be async signal safe, it's OK since glog's stacktrace doesn't depend on signals. git-svn-id: https://google-glog.googlecode.com/svn/trunk@7 eb4d4688-79bd-11dd-afb4-1d65580434c0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 683247a..1012276 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,9 @@ AC_CHECK_TYPE(__uint16, ac_cv_have___uint16=1, ac_cv_have___uint16=0)
AC_CHECK_FUNC(sigaltstack,
AC_DEFINE(HAVE_SIGALTSTACK, 1,
[Define if you have the `sigaltstack' function]))
+AC_CHECK_FUNC(dladdr,
+ AC_DEFINE(HAVE_DLADDR, 1,
+ [Define if you have the `dladdr' function]))
AX_C___ATTRIBUTE__
# We only care about these two attributes.