summaryrefslogtreecommitdiff
path: root/tests/gobject/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gobject/Makefile.am')
-rw-r--r--tests/gobject/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/gobject/Makefile.am b/tests/gobject/Makefile.am
index 656941db1..aa5dbb602 100644
--- a/tests/gobject/Makefile.am
+++ b/tests/gobject/Makefile.am
@@ -22,6 +22,7 @@ installed_test_programs = \
signals \
singleton \
references \
+ testgobject \
$(NULL)
# Don't install these ones, and keep them out of 'make check' because they take too long...
@@ -43,6 +44,7 @@ accumulator_SOURCES = accumulator.c testmarshal.c testmarshal.h
signals_SOURCES = signals.c
defaultiface_SOURCES = defaultiface.c testmodule.c testmodule.h
dynamictype_SOURCES = dynamictype.c testmodule.c testmodule.h
+testgobject_SOURCES = testgobject.c
if ENABLE_TIMELOOP
installed_test_programs += timeloop-closure
@@ -55,12 +57,12 @@ glib_genmarshal=$(top_builddir)/gobject/glib-genmarshal
testmarshal.h: stamp-testmarshal.h
@true
-stamp-testmarshal.h: @REBUILD@ testmarshal.list $(glib_genmarshal)
+stamp-testmarshal.h: testmarshal.list $(glib_genmarshal)
$(AM_V_GEN) $(glib_genmarshal) --prefix=test_marshal $(srcdir)/testmarshal.list --header >> xgen-gmh \
&& (cmp -s xgen-gmh testmarshal.h 2>/dev/null || cp xgen-gmh testmarshal.h) \
&& rm -f xgen-gmh xgen-gmh~ \
&& echo timestamp > $@
-testmarshal.c: @REBUILD@ testmarshal.h testmarshal.list $(glib_genmarshal)
+testmarshal.c: testmarshal.h testmarshal.list $(glib_genmarshal)
$(AM_V_GEN) (echo "#include \"testmarshal.h\""; $(glib_genmarshal) --prefix=test_marshal $(srcdir)/testmarshal.list --body) >> xgen-gmc \
&& cp xgen-gmc testmarshal.c \
&& rm -f xgen-gmc xgen-gmc~