summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHyunjee Kim <hj0426.kim@samsung.com>2019-12-03 09:46:57 +0900
committerHyunjee Kim <hj0426.kim@samsung.com>2019-12-03 09:46:57 +0900
commit2edc4beaf99a0eb139005443a9ed9ebad1d4cf5f (patch)
tree2f1062b20f87d04526d39be4fe68d55500bd45ab /configure.ac
parent199bcd7237c3abbe4c62cdc742a3396301de64c0 (diff)
downloadglib-2edc4beaf99a0eb139005443a9ed9ebad1d4cf5f.tar.gz
glib-2edc4beaf99a0eb139005443a9ed9ebad1d4cf5f.tar.bz2
glib-2edc4beaf99a0eb139005443a9ed9ebad1d4cf5f.zip
Imported Upstream version 2.55.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 27 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 0457c90b8..5cbff1919 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,9 +30,9 @@ m4_define(glib_configure_ac)
# <mclasen> on the unstable (ie master), interface age = 0
m4_define([glib_major_version], [2])
-m4_define([glib_minor_version], [54])
-m4_define([glib_micro_version], [3])
-m4_define([glib_interface_age], [3])
+m4_define([glib_minor_version], [55])
+m4_define([glib_micro_version], [0])
+m4_define([glib_interface_age], [0])
m4_define([glib_binary_age],
[m4_eval(100 * glib_minor_version + glib_micro_version)])
m4_define([glib_version],
@@ -63,7 +63,7 @@ AC_CONFIG_MACRO_DIR([m4macros])
# Save this value here, since automake will set cflags later
cflags_set=${CFLAGS:+set}
-AM_INIT_AUTOMAKE([1.11 -Wno-portability no-define no-dist-gzip dist-xz tar-ustar])
+AM_INIT_AUTOMAKE([1.13.3 -Wno-portability no-define no-dist-gzip dist-xz tar-ustar subdir-objects])
AM_MAINTAINER_MODE([enable])
# Support silent build rules. Disable
@@ -144,7 +144,7 @@ case "$host" in
;;
esac
- AC_DEFINE([_WIN32_WINNT], [0x0501], [Target the Windows XP API])
+ AC_DEFINE([_WIN32_WINNT], [0x0601], [Target the Windows 7 API])
;;
*)
glib_native_win32=no
@@ -369,16 +369,6 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
-# Need full path to Perl for glib-mkenums
-#
-if test "x$PERL" != x ; then
- AC_PATH_PROG(PERL_PATH, [$PERL])
-fi
-if test "x$PERL_PATH" = x ; then
- PERL_PATH="/usr/bin/env perl"
-fi
-AC_SUBST(PERL_PATH)
-
# option to specify python interpreter to use; this just sets $PYTHON, so that
# we will fallback to reading $PYTHON if --with-python is not given, and
# python.m4 will get the expected input
@@ -700,7 +690,7 @@ AM_CONDITIONAL(HAVE_SUNSTUDIO_VISIBILITY, [test x$g_have_sunstudio_visibility =
# check for bytesex stuff
AC_C_BIGENDIAN
if test x$ac_cv_c_bigendian = xuniversal ; then
- AC_MSG_ERROR([Universal builds not supported: see https://bugs.gnome.org/742548])
+ AC_MSG_ERROR([Universal builds not supported: see https://bugzilla.gnome.org/show_bug.cgi?id=742548])
fi
@@ -890,7 +880,7 @@ int main ()
AC_MSG_RESULT($glib_ssize_type)
# Check for some functions
-AC_CHECK_FUNCS(lstat strsignal vsnprintf stpcpy strcasecmp strncasecmp poll vasprintf setenv unsetenv getc_unlocked readlink symlink fdwalk)
+AC_CHECK_FUNCS(lstat strsignal vsnprintf stpcpy strcasecmp strncasecmp poll vasprintf setenv unsetenv getc_unlocked readlink symlink fdwalk mkostemp)
AC_CHECK_FUNCS(lchmod lchown fchmod fchown utimes getresuid)
AC_CHECK_FUNCS(getmntent_r setmntent endmntent hasmntopt getfsstat getvfsstat fallocate)
case $host_os in aix*) ac_cv_func_splice=no ;; esac # AIX splice() is something else
@@ -961,6 +951,22 @@ fi
AC_CHECK_FUNCS(endservent if_nametoindex if_indextoname sendmmsg recvmmsg)
+AC_MSG_CHECKING([for SIOCGIFADDR])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
+ [[
+ #include <sys/ioctl.h>
+ #include <net/if.h>
+ ]],
+ [[
+ struct ifreq ifr;
+ ioctl(0, SIOCGIFADDR, &ifr);
+ ]])], [
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_SIOCGIFADDR, 1, [SIOCGIFADDR is available])
+ ], [
+ AC_MSG_RESULT(no)
+])
+
AS_IF([test $glib_native_win32 = yes], [
# <wspiapi.h> in the Windows SDK and in mingw-w64 has wrappers for
# inline workarounds for getaddrinfo, getnameinfo and freeaddrinfo if
@@ -1754,8 +1760,10 @@ AS_IF([ test $have_libmount = maybe ], [
glib_save_LIBS=$LIBS
AC_CHECK_HEADER([libmount/libmount.h], [:], [have_libmount=no])
- # Check for a recent enough libmount
- AC_CHECK_LIB([mount], [mnt_unref_table], [:], [have_libmount=no])
+ # We used to check for mnt_unref_table(), but now for compat with
+ # e.g. RHEL7 just use mnt_free_table(). Let's keep this check
+ # anyways.
+ AC_CHECK_LIB([mount], [mnt_free_table], [:], [have_libmount=no])
LIBS=$glib_save_LIBS
if test $have_libmount != no; then