summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Szyndela <adrian.s@samsung.com>2020-01-17 16:50:13 +0100
committerAdrian Szyndela <adrian.s@samsung.com>2020-01-28 13:25:12 +0100
commit3c459edd259acca50370d3c1362a68f7fe8625f6 (patch)
tree19ecfe7da3cb32154db6c7db0b11eab1b3157b46 /configure.ac
parent7aa26230d66c82ebcbf5e2f4419efc96ed4cdc9d (diff)
parenta60402374ac62bf99a22f84f0801d5513b12fd66 (diff)
downloadglib-3c459edd259acca50370d3c1362a68f7fe8625f6.tar.gz
glib-3c459edd259acca50370d3c1362a68f7fe8625f6.tar.bz2
glib-3c459edd259acca50370d3c1362a68f7fe8625f6.zip
Merge 2.59.0 into tizen
Change-Id: I5fce88747c10d0f110d405e1e6be536d0cc8f2d0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e7f05efdb..28df6795d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,9 +30,9 @@ m4_define(glib_configure_ac)
# <mclasen> on the unstable (ie master), interface age = 0
m4_define([glib_major_version], [2])
-m4_define([glib_minor_version], [58])
-m4_define([glib_micro_version], [3])
-m4_define([glib_interface_age], [3])
+m4_define([glib_minor_version], [59])
+m4_define([glib_micro_version], [0])
+m4_define([glib_interface_age], [0])
m4_define([glib_binary_age],
[m4_eval(100 * glib_minor_version + glib_micro_version)])
m4_define([glib_version],
@@ -63,7 +63,7 @@ AC_CONFIG_MACRO_DIR([m4macros])
# Save this value here, since automake will set cflags later
cflags_set=${CFLAGS:+set}
-AM_INIT_AUTOMAKE([1.13.3 -Wno-portability no-define no-dist-gzip dist-xz tar-ustar subdir-objects])
+AM_INIT_AUTOMAKE([1.13.3 -Wno-portability no-define no-dist-gzip dist-xz tar-ustar subdir-objects foreign])
AM_MAINTAINER_MODE([enable])
# Support silent build rules. Disable
@@ -353,12 +353,12 @@ AC_PROG_AWK
# python.m4 will get the expected input
AC_ARG_WITH(python,
AS_HELP_STRING([--with-python=PATH],
- [Path to Python interpreter; searches $PATH if only a program name is given; if not given, searches for a few standard names such as "python3" or "python2"]),
+ [Path to Python interpreter; searches $PATH if only a program name, such as "python3" or "python3.4", is given; if not given, searches for a few standard names]),
[PYTHON="$withval"], [])
if test x"$PYTHON" = xyes; then
AC_MSG_ERROR([--with-python option requires a path or program argument])
fi
-AM_PATH_PYTHON(2.7,,PYTHON="python2.7")
+AM_PATH_PYTHON(3.4,,[AC_MSG_ERROR([Requires Python >=3.4])])
dnl ***********************
@@ -877,6 +877,7 @@ AC_CHECK_FUNCS(getmntent_r setmntent endmntent hasmntopt getfsstat getvfsstat fa
case $host_os in aix*) ac_cv_func_splice=no ;; esac # AIX splice() is something else
AC_CHECK_FUNCS(splice)
AC_CHECK_FUNCS(prlimit)
+AC_CHECK_FUNCS(getauxval)
# To avoid finding a compatibility unusable statfs, which typically
# successfully compiles, but warns to use the newer statvfs interface:
@@ -2623,7 +2624,7 @@ AS_IF([ test "x$use_gcov" = "xyes"], [
AC_MSG_ERROR([ccache must be disabled when --enable-coverage option is used. You can disable ccache by setting environment variable CCACHE_DISABLE=1.])
fi
- ltp_version_list="1.6 1.7 1.8 1.9 1.10 1.12"
+ ltp_version_list="1.6 1.7 1.8 1.9 1.10 1.12 1.13"
AC_CHECK_PROG(LTP, lcov, lcov)
AC_CHECK_PROG(LTP_GENHTML, genhtml, genhtml)